.NET Framework [Résolu]

Signaler
-
 damo1 -
Bonjour,

Est-ce que quelqu'un peut m'expliquer la difference entre .NET Framework 4 et la version Client Profile? Dans quel cas utiliser l'un ou l'autre?

Merci d'avance!

6 réponses

J'ai aussi trouve pas mal de reponse ici:

http://blogs.msdn.com/b/jgoldb/archive/2010/04/12/what-s-new-in-net-framework-4-client-profile-rtm.aspx

En fait il y a a peu pres tout: comment choisir entre client profile et version complete, et comment passer d'un framework a un autre!
Messages postés
16013
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
8 juin 2021
549
Bon je ne suis pas encore un expert... qu'est-ce qu'une application cliente?

Mon probleme est que apres avoir commence une application sur Visual Studio, je me suis rendu compte qu'elle etait en .NET Framework 2. J'ai voulu passer en version 4 mais quand je build, j'ai un message d'erreur qui m'indique que je dois passer en mode Client Profile:

"The target version of the .NET Framework in the project does not match the .NET Framework launch condition version '.NET Framework 4 Client Profile'. Update the version of the .NET Framework launch condition to match the target version of the.NET Framework in the Advanced Compile Options Dialog Box (VB) or the Application Page (C#, F#)."

Je ne trouve pas comment regler ce probleme...
Messages postés
16013
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
8 juin 2021
549
Je ne suis pas un spécialiste des application client/serveur, mais si j'en crois l'article en lien plus haut si tu passes en framework 4.5 tu n'as pas à te poser la question.


Whismeril
Avec Visual Studio 2010, je n'ai pas l'option 4.5...

J'ai essaye en commencant une nouvelle application, en selectionnant correctement .NET Framework 4 au debut mais quand je la publie avec un "Setup Project" il rebascule automatiquement en Client Profile (dans .NET Framework Launch Condition Properties).

Si je change manuellement pour la version 4, j'obtiens le message d'erreur ci-dessus!
Messages postés
16013
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
8 juin 2021
549
http://www.microsoft.com/fr-fr/download/details.aspx?id=30653
Mais apparemment il lui faut Vista, Seven ou W8


Whismeril