Formule Somme avec derniere lignes qui varie [Résolu]

Messages postés
53
Date d'inscription
jeudi 29 mars 2012
Statut
Membre
Dernière intervention
9 juin 2012
- - Dernière réponse : walyddu59
Messages postés
53
Date d'inscription
jeudi 29 mars 2012
Statut
Membre
Dernière intervention
9 juin 2012
- 30 mai 2012 à 10:42
Bonjour le forum,

Je me retrouve avec un nouveaux problème de formules
=SOMME(D8:dernière ligne qui varie )/SOMME(B8:dernière ligne qui varie )
, donc je calcule une somme d'une plage jusque la tout va bien , le problème et que la dernier ligne de la plage de somme varie donc je n'arrive pas écrire ma formule , j'ai essayer avec ceci
[code=vb]=RECHERCHEV(9^9;A:A;1)
/code mais rien n'y fait , cela ne fonctionne pas car il me donne juste la dernière valeur de la colonne , merci d'avance pour toute solution apporter .
Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
53
Date d'inscription
jeudi 29 mars 2012
Statut
Membre
Dernière intervention
9 juin 2012
3
Merci
Salut,

donc voici la solution que j'ai obtenue par aide :
=SOMME(D:D)/SOMME(B:B)

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 196 internautes nous ont dit merci ce mois-ci

Commenter la réponse de walyddu59
Messages postés
1839
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
20 novembre 2013
8
3
Merci
erratum :

Dim Lig2 as Long
Dim MaFeuille As WorkSheet
Set MaFeuille = ActiveSheet 'la feuille étant un objet l'instruction "Set" est obligatoire
With MaFeuille
   Lig2 = .Range("A" & .Columns("A").Rows.Count).End(xlUp).Row
   .Range("A2").Value = Application.WorksheetFunction.Max(.Range("K8:K" & Lig2))
End With


A+

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 196 internautes nous ont dit merci ce mois-ci

Commenter la réponse de bigfish_le vrai
Messages postés
53
Date d'inscription
jeudi 29 mars 2012
Statut
Membre
Dernière intervention
9 juin 2012
0
Merci
re-salut ,

j'ai une dernière formule a adapter du même genre celle-ci permet de connaitre la valeur max sur une colonne je veux l’intégrer a ma macro donc j'ai crée une variable Lig2 qui me permettra de connaitre la dernière ligne de la colonne et ainsi réaliser mon calcule . formule
 ActiveCell.FormulaR1C1 = "=VLOOKUP(9^9,C,1)"
et macro
Dim Lig1 As Long, Lig2 As Long

Lig2 = 'ici que je veux  connaitre la dernière ligne de la colonne A
Range("A2").Formula = "=MAX(K8:K" & Lig2 & ")"
'

End Sub


En espérant que cela fonctionne , merci .
Commenter la réponse de walyddu59
Messages postés
1839
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
20 novembre 2013
8
0
Merci
Salut,

pas besoin d’écrire la formule dans la cellule de résultat puisque seul la valeur t’intéresse. Pour cela il est possible d'utiliser un certain nombre de fonction excel dans le VBA via la propriété "WorksheetFunction".
Prend aussi l'habitude de spécifier la feuille sur la quelle tu travailles pour éviter les ennuis. Comme je ne connais pas le nom de la feuille j'ai fait autrement mais cela revient à peu près au même

Dim Lig2 as Long
MaFeuille As WorkSheet
Set MaFeuille = ActiveSheet
With MaFeuille
   Lig2 = .Range("A" & .Columns("A").Rows.Count).End(xlUp).Row
   .Range("A2").Value = Application.WorksheetFunction.Max(.Range("K8:K" & Lig2))
End With



A+
Commenter la réponse de bigfish_le vrai
Messages postés
53
Date d'inscription
jeudi 29 mars 2012
Statut
Membre
Dernière intervention
9 juin 2012
0
Merci
Salut,

Merci pour la solution et le conseil , oui déclaré la feuille évite certains problèmes .
Commenter la réponse de walyddu59