Problème avec le Runtime

Signaler
Messages postés
82
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
24 novembre 2012
-
Messages postés
82
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
24 novembre 2012
-
Bonjour,

J'ai un probleme sous eclipse, lorsque j'excute mon programme il mafiche un message derreur :
/usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar has no source attachement

Comment je pourrai configurer eclipse pour faire attachment de source?
Merci
A voir également:

6 réponses

Messages postés
6414
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
29 juillet 2020
360
Bonjour,

Tu as un problème avec ton JRE. As tu bien installé un JDK ou un JRE java ?

Normalement, éclipse doit le détecter automatiquement. Pour le savoir : Fenetre : Preferences.

Ensuite, tu cliques sur "Java" et enfin sur "JRE installés". Si tu ne trouves pas ton JRE dans cette liste, tu peux faire "Ajouter" et tu sélectionnes alors le dossier d'installation de ton JRE.
Messages postés
82
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
24 novembre 2012

Bonjour,

J'ai trouvé le java-6-openjdk dans les "JRE installés ".
Que fais je ?
Tu as une autre solution à me proposée ?

Merci
Messages postés
6414
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
29 juillet 2020
360
Tu utilises bien java 6 dans ton build path ? Click droit sur le projet puis build path et enfin configure. Est ce que c'est bien JRE6 ?
Messages postés
82
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
24 novembre 2012

oui j'ai trouvé "JRE System Librairy [javaSE-1.6]"
Messages postés
6414
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
29 juillet 2020
360
En général, cette erreur survient quand le JDK n'est pas installé correctement. Dans ton cas, je ne vois pas trop d'ou ca peut venir.

Désolé.
Messages postés
82
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
24 novembre 2012

Merci en tout cas, je vais essayer de trouver la solution