WinXP Engine.ocx

Signaler
Messages postés
8
Date d'inscription
mardi 22 mars 2005
Statut
Membre
Dernière intervention
3 mars 2012
-
Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
-
Chèr Experts,

J'use WinXP Engine.ocx dans mon logiciel en Visual Basic 6.0 et ca marche presque parfait. Un (petit?) problème: si je lance et ferme le programme quelque fois successivement (4 ou 5), l'effet-XP est parti et mon computer arrète. Pouvez vous m'aider?

Merci!
Lauran van Oers
Les Pays Bas
Lvanoers@hotmail.com

7 réponses

Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
68
sous quel OS travailles tu ?

Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
8
Date d'inscription
mardi 22 mars 2005
Statut
Membre
Dernière intervention
3 mars 2012

Bonjour,

Mon logiciel est programmé sous Windows XP. J'ai des problèmes avec WinXPC Engine.ocx si j'use le programme avec Vista et 7. Sans WinXPC Engine.ocx, j'ai aucun problème.

Cordialement,
Lauran van Oers
Les Pays Bas
Lvanoers@hotmail.com
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
68
Pourquoi l'utiliser ?
utilises un .manfest pour donner le look xp (/Seven) a tes Forms, directement...

Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
8
Date d'inscription
mardi 22 mars 2005
Statut
Membre
Dernière intervention
3 mars 2012

Bonsoir,

Merci pour votre réponse rapide. J'ai aussi utilisé un .manifest dans des programmes divèrs, mais ce logiciel est trop compliqué, avec beaucoup des forms, grands boutons, des frames etc. Il faut par exemple mettre tous les frames et les optionbuttons in a picturebox et il reste un problème avec des grands boutons. Avec WinXPC Engine.ocx ca va en principe très vite: mettre ca sur les forms et voila.

Cordialement,
Lauran van Oers
Les Pays Bas
Lvanoers@hotmail.com
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
68
ca fait penser a un bug de l'ocx...

dur de régler cela, en ce cas


Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
8
Date d'inscription
mardi 22 mars 2005
Statut
Membre
Dernière intervention
3 mars 2012

Bonjour,

Si vous voulez:
http://www.vbfrance.com/codes/COMPOSANTS-XP-SUBCLASSING_34523.aspx

Trop difficile pour moi (comme la langue Francaise) a voir pourqoi ca donne des problemes en Vista et 7 et pas en XP.

Cordialement,
Lauran van Oers
Les Pays Bas
Lvanoers@hotmail.com
Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
234
Bonjour,
parce que tout simplement ton ocx ou/et ton appli utilisent des composants ou librairies non présente nativement sous Vista :
C'est par exemple le cas de COMDLG32.OCX
Lis donc attentivement ceci
Tapez le texte de l'url ici.
Il te faudra probablement télécharger et enregistrer certains fichiers.


____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient