Problème somme.si excel

Résolu
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015 - 16 févr. 2012 à 08:25
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015 - 16 févr. 2012 à 15:44
Bonjour les ptis loups,

Voici mon problème en quelques lignes :

=SOMME.SI(J8:AN26;H3;F8:F26)

J8:AN26 (plage critère)
H3 (critère)
F8:F26 (somme plage)

Lorsque je mets le critère H3 dans la colonne "J" la somme se fait correctement. Par contre dès que je me décale dans les colonnes "K", "L"... pour entrer le critère H3 la formule ne fonctionne plus.

Pouvez vous m'aider?

Merci.

14 réponses

ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 15:44
Avec perseverance j'ai trouvé!

Alors pour infos!

On passe par la formule:

SOMMEPROD((J8:AN521"X")*(F8:F521))

Bisous
3
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 09:04
Bonjour
= SOMME.SI(J8:AN26; $H$3 ;F8:F26)
donc, pour que H3 soit absolue et non relative !



____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 09:54
Je viens d'essayer avec la solution proposée ci-dessus mais j'ai toujours le même problème.

Le calcule se fait bien lorsque je rentre le critère dans la colone "J" mais dès que je le rentre dans la colone "K" par exemple la somme n'est pas prise en compte.

j'aimerai mettre mon tableau en fichier joint pour faciliter la comprhension mais je n'y arrive pas!

Merci.
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 10:24
j'aimerai mettre mon tableau en fichier joint pour faciliter la comprhension mais je n'y arrive pas!

Lis donc la dernière ligne du commentaire affiché dans mon profil;
Si les choses sont claires dans ton esprit, tu dois pouvoir les exprimer clairement et avec concision.
T'as des difficultés ? == >Q> suggestion, alors :
Quelle serait la formule que tu voudrais obtenir par étirement sur 2 lignes consécutives :
celle de la première ligne et celle de la seconde
etr sans embrouiller par d'autres explications.
____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 10:38
Oui je pense que la formule à obtenir doit être par étirement comme tu le propose, mais pas simplement sur 2 mais plusieurs lignes. Je ne pense pas que la formule "somme.si" puisse faire cela, je regarde aussi de mon côté pour le "sommeprod".

Merci
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 10:43
Je me moque éperdument du nombre de lignes sur lesquelles ta formule sera étirée !
Je te demande simplement, très simplement, de bien vouloir me montrer ici ce que je t'ai demandé (puisque tu as des difficultés à exposer techniquement) :
Pour mémoire :
Quelle serait la formule que tu voudrais obtenir par étirement sur 2 lignes consécutives :
celle de la première ligne et celle de la seconde

C'est difficile à comprendre ?


____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 10:49
SOMME.SI(J8;H3;F8:F26)
SOMME.SI(K8;H3;F8:F26)

Par exemple:
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 10:53
et donc ?
Si c'est ce que tu veux obtenir par étirement :
H3, F8 et F26 sont répétées, donc adresses absolues et non relatives ===>>
SOMME.SI(J8;$H$3;$F$8:$F$26)
seule J8 reste relative
(sans préjudice de la justesse de ta formule. Juste le principe de notation de la formule)


____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 11:08
Je viens d'essayer cette formule grand chef en vain!

=SOMME.SI(J8:AN26;$H$3;$F$8:$F$26)

En faite je voudrais dans une même formule toutes ces formules ci-dessous :
=SOMME.SI(J8;$H$3;$F$8:$F$26)
=SOMME.SI(J9;$H$3;$F$8:$F$26)
.....
=SOMME.SI(K8;$H$3;$F$8:$F$26)
...
=SOMME.SI(AN26;$H$3;$F$8:$F$26)
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 11:21
En étirant comment ?
Tes deux premières formules résultent d'un étirement vers le bas
les autres semblent correspondre à un étirement vers la droite !

A moins que tu n'aies mis une formule dans chaque colonne concernée, étirée ensuite vers le bas ?
Si c'est cela :
tu mets ta première formule dans la cellule de départ, puis :
tu l'étires vers la droite sur tes colonnes concernées, puis
tu étires vers le bas l'ensemble (la sélection de toute les colonnes de la première ligne).

____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 11:32
En faite c'est un peu plus compliqué que ça!

Je ne veux faire qu'une seule formule:

exemple:

A B C D
1 23
2 22
3 34


Si je mets mon critère dans D2 la formule doit me calculer 22
Si je mets mon critère dans D2 et C2 la formule doit me calculer 44
Si je mets mon critère dans B1 et D3 la formule doit me calculer 57

Je pense que la tu va mieux comprendre!
0
ucfoutu Messages postés 18038 Date d'inscription lundi 7 décembre 2009 Statut Modérateur Dernière intervention 11 avril 2018 236
16 févr. 2012 à 11:40
Non...
je ne comprends pas un tel mécanisme.
Bonne chance


____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 11:42
Tu as quand même compris mon explication ou pas ?
0
ticrain Messages postés 178 Date d'inscription jeudi 15 mars 2007 Statut Membre Dernière intervention 2 janvier 2015
16 févr. 2012 à 14:28
Besoin d'aide!
0