SOMMPROD avec notion de VALEURS TEXTE proches à distinguer

Signaler
Messages postés
39
Date d'inscription
mardi 12 août 2008
Statut
Membre
Dernière intervention
17 juillet 2012
-
Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
-
Bonjour,

Dans le carde d'un programme excel je m'arrache les cheveux avec cette fonction ...

=SOMMEPROD((ESTNUM(CHERCHE(($B23);'BHN 2012.1'!$B$6:$B$1717))*'BHN 2012.1'!$AP$6:$AP$1717))


Pour essayer d'être clair:

je possède un tableau avec un première colonne intitulée TYPE DE PRELEVEMENT et un deuxième colonne intitulée ACTIVITEE DE LABORATOIRE EN BHN.

Je calcul pour chaque type de prélèvement l'activitée engendrée pour l'année grâce à cette formule qui va rechercher toutes les activités dans une autre feuilles correspondant au type de prélèvement.

Je suis embetté lorsque les noms des types de prélèvement s'apparentent.

Exemple AIR et DENTAIRE même en ajoutant un astérisque à AIR* pour que la fonctionne comprenne qu'il ne s'agit pas du même mot cela ne fonctionne pas... Ainsi elle me donne pour le type de prélèvement DENTAIRE l'activité totale AIR + DENTAIRE.


Merci pour votre aide.

1 réponse

Messages postés
18038
Date d'inscription
lundi 7 décembre 2009
Statut
Modérateur
Dernière intervention
11 avril 2018
239
Bonjour,
Ce que tu vmontres n'est pas du VBA/Excel, mais du Excel "tout court" .
Si tu tiens à utiliser les formules de Excel, tu ne pourras arriver à faire ce que tu veux faire, tant pour CHERCHE, que pour RECHERCHE ou pour EQUIV, qu'en triant préalablement de manière ascendante la colonne concernée.
Sinon ===>> passer par la méthode Find de VBA


____________________
Réponse exacte ? => "REPONSE ACCEPTEE" pour faciliter les recherches d'autres forumeurs.
Pas d'aide en ligne installée ? ==> ne comptez pas sur moi pour simplement vous dire ce qu'elle contient