DBExpress et mysql

salut_2006 Messages postés 6 Date d'inscription jeudi 30 mars 2006 Statut Membre Dernière intervention 17 février 2012 - 28 déc. 2011 à 15:28
beckerich Messages postés 302 Date d'inscription jeudi 29 septembre 2005 Statut Membre Dernière intervention 17 septembre 2013 - 29 déc. 2011 à 13:03
Bonjour tout le monde, voilà je fais une application avec delphi7 et j'essaie de connecter une base de données mysql avec le composant DBExpress mais j'ai ce message d'erreur "nom d'utilisateur/mot de passe incorrect" bien que je rentre le nom d'utilisateur root et le password vide mais ça marche pas . je précise que je travaille avec wampserver 2.2 (mysql 5.5.16). quelqu'un pourrait me dire c'est dû à quoi merci d'avance

4 réponses

salut_2006 Messages postés 6 Date d'inscription jeudi 30 mars 2006 Statut Membre Dernière intervention 17 février 2012
28 déc. 2011 à 20:23
personne pour me répondre
0
beckerich Messages postés 302 Date d'inscription jeudi 29 septembre 2005 Statut Membre Dernière intervention 17 septembre 2013 2
29 déc. 2011 à 11:53
bonjour,

le mot de passe de root est vide dans la base de données ?
Si non, il faut le passer comme paramètre.

Luc.
0
salut_2006 Messages postés 6 Date d'inscription jeudi 30 mars 2006 Statut Membre Dernière intervention 17 février 2012
29 déc. 2011 à 12:51
Bonjour beckerich merci pour la réponse; oui le mot de passe est vide dans phpmyadmin, ça a fonctionné en installant le CMS joomla
0
beckerich Messages postés 302 Date d'inscription jeudi 29 septembre 2005 Statut Membre Dernière intervention 17 septembre 2013 2
29 déc. 2011 à 13:03
bonjour,

attention, pour certaines bases de données, une valeur vide et une valeur nulle ne sont pas la même chose... Mysql, aucune expérience, essayes les 2, ou voit ici, peutêtre tu trouves ton bonheur
ici
0
Rejoignez-nous