Problème : modif de clip non visible [Résolu]

Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015
- - Dernière réponse : bencoandco
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015
- 21 déc. 2011 à 20:01
Bonjour !


J'ai un problème avec as 2.0. Je modifie la taille d'un clip en script mais la modification n'est pas effective visuellement, quand je récupère la taille du clip j'ai la bonne taille mais mais visuellement la taille du clip semble être restée à l'ancienne valeur... Il me semble qu'il y ait l'équivalent de repaint en flash... y a t il une fonction pour actualiser la scène principale pour que les modif soient visible ?

voici le code de modif de la taille :



fscommand("fullscreen", true);
Stage.align = "TL";
Stage.scaleMode = "noScale";

max_height = 87+30;
max_width  = 200+30;



panel_viewer._width  = max_width;
panel_viewer._height = max_height;



visuellement le clip est à width=287 (taille de base) mais quand je récupère la taille avec trace j'ai width=230.
Merci pour vos rep !
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015
3
Merci
apparemment le problème venait du paramètre xscale que je n'avais pas pris en compte !

la question reste en suspend pour une fonction équivalente à repaint ....

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 127 internautes nous ont dit merci ce mois-ci

Commenter la réponse de bencoandco