Problème d'envoi d'une structure (bizarre)

Signaler
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011
-
Messages postés
15
Date d'inscription
samedi 8 septembre 2012
Statut
Membre
Dernière intervention
11 juin 2015
-
Bonjour,

je suis entrain de créer un programme qui permet de manipuler des annuaires sur un serveur depuis un client.
Pour cela j'ai décidé de transmettre une structure contenant les informations.
Mais j'ai un problème (plutôt bizarre je trouve), lorsque je renseigne les champs de ma structure dans le main.c et que j'envoi, tout se passe bien, hors quand je décide de renseigner les champs grâce à une fonction se trouvant sur un fichier client.c (prototype dans client.h), lors de l'envoi le serveur ne reçoit rien ou rien de bon. Alors que je fait la même chose.

[b]
Voilà ce que je fais dans le main quand ça marche (p2 est ma structure composée d'idReq et de data):/b

[i]char *typeReq= "creatA";
strcpy(p2.idReq,typeReq);

printf("Entrez le nom de l'annuaire\n");
scanf("%s",annuaire);
strcpy(p2.data,annuaire);

Emission(p2,1024);/i


Voilà ce que je fais quand ça ne marche pas :

main.c :

[i]creatA(&p2);
Emission(p2,1024);/i

client.c :

[i]void creatA(req p2)
{
char ann[30];
char *idReq = "creatA";
printf("entrer nom de l'ann\n");
scanf("%s",ann);

strcpy(p2->idReq,idReq);
strcpy(p2->data,ann);
}/i



J'attends vos explications.

Merci beaucoup


Pedro

12 réponses

Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
66
comment est déclarée p2 ?
comment est définit req ?

vu ton code, cela doit être un pointeur de structure.
si tel n'est pas le cas, ton soucis est là


Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011

[i]typedef struct
{
char idReq[13];
char data[500];
}requete, *req;


requete p2;/i

Je viens de remarquer que quand le serveur recevez la structure, dans idReq il ne recever que ce qu'il devrait y avoir dans data à partir du 4ème caractère. J'ai de plus en plus de mal à comprendre.

ex : idReq = "creatA"
data = "test"
j'envoi et le serveur reçoit :
idReq = "t"
data = ""

Merci beaucoup de votre aide

Pedro
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
66
surement un probleme d'UNICODE / ASCII ??


Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011

Je ne sais pas du tout, comment je pourrais vérifier ça ?

J'ai testé plein de chose je comprend pas du tout ce qui se passe (je désespère un peu).

Merci


Pedro
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
66
va falloir nous montrer un peu plus de code (emission/reception)

Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011

Ma fonction emission :
[i]int Emission(requete donnees, size_t taille)
{
int retour = 0;
retour = send(socketClient, &donnees, taille, 0);
if(retour == -1) {
perror("Emission, probleme lors du send.");
return -1;
} else {
return retour;
}
}/i

Ma fonction réception :
[i]int Reception(requete donnees, size_t tailleMax)
{
int retour = 0;
retour = recv(socketService, &donnees, tailleMax, 0);
return retour;
}/i


Je fais plein de test depuis tout à l'heure et j'ai remarqué que si dans le main je faisais :
strcpy(p2.idReq, "test") et que j'envoyer j'avais le même problème,mais si je met "test" dans une variable et que je fait le strcpy avec cette variable ça fonctionne...

Merci pour votre aide

Pedro
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
66
client et serveurs tournent sur la même machine ?
sur le même type de machine ?

il est dangereux de vouloir envoyer directement des structures...

alignement, LE/BE, Unicode/Ascii...

les raisons d'une defaillance possible sont nombreuses

Il vaudrait mieux que tu serialise, pour n'envoyer qu'une suite d'octet dont la structure in-memory est connue

Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011

Oui c'est sur la même machine. Je pense que je vais devoir changer de méthode car je viens d'essayer la même mais juste en transmettant une chaîne de caractère et cela fonctionne...
Que me conseiller vous :
-envoyer une chaîne de caractère qui contiendrait mes 2 champs de structure
ou
-envoyer une premiere chaîne avec le premier champ idReq puis une seconde avec le champ data
?

Merci beaucoup.


Pedro
Messages postés
21042
Date d'inscription
jeudi 23 janvier 2003
Statut
Modérateur
Dernière intervention
21 août 2019
24
int Emission(requete donnees, size_t taille);

On ne passe jamais la structure à un fonction.
Il y aurait copie inutile.
On passe toujours un pointeur vers la structure.

int Emission(req pdata, size_t taille);

ciao...
BruNews, MVP VC++
Messages postés
6
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
21 décembre 2011

BruNews : tout d'abord merci pour ton aide, mais cela ne fonctionne pas. J'ai fait ceci:
[i]int Emission(req pdonnees, size_t taille)
{
int retour = 0;
retour = send(socketClient,pdonnees, 1024, 0);
if(retour == -1) {
perror("Emission, probleme lors du send.");
return -1;
} else {
return retour;
}
}/i

en appelant comme ceci :
[i]req pp2;
pp2=&p2;
Emission(pp2);
/i

Merci

Pedro
Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
66
simple reecriture, sur que cela ne résoudra pas ton probleme...


Renfield - Admin CodeS-SourceS - MVP Visual Basic & Spécialiste des RegExp
Messages postés
15
Date d'inscription
samedi 8 septembre 2012
Statut
Membre
Dernière intervention
11 juin 2015

Le problème vient de ta fonction de réception.
int Reception(requete donnees, size_t tailleMax)
Ta variable "donnees" et son contenu (puisque ici, c'est une structure) n'a d'existence qu'au sein de ta fonction. Dès que tu sors de la fonction les données n'existe plus.
Il faut simplement envoyer l'adresse de ta variable.
int Reception(requete *pDonnees, size_t tailleMax)
{
int retour = 0;
retour = recv(socketService, pDonnees, tailleMax, 0);
return retour;
}

main(...)
{
requete donnees = {0,};

if (Reception(&donnees, sizeof(donnees)) < 0)
{
// Erreur
}
else
{
printf("idReq=%s\n", donnees.idReq);
printf("data =%s\n", donnees.data);
}
}