Probleme avec "svnadmin create /path/to/jobeet/repository"

khaled001 Messages postés 156 Date d'inscription mardi 19 août 2008 Statut Membre Dernière intervention 8 août 2016 - 26 nov. 2011 à 20:44
TychoBrahe Messages postés 1309 Date d'inscription samedi 31 janvier 2009 Statut Membre Dernière intervention 5 juin 2013 - 27 nov. 2011 à 13:43
Salut

j'ai un probleme avec symfony quand j'introduit la commande : svnadmin create /path/to/jobeet/repository j'ai ce reseultat la :

root@khaled:/home/khaled# svnadmin create /path/to/jobeet/repository
Le programme « svnadmin » n'est pas installé.  Vous pouvez l'installer en saisissant :
apt-get install subversion
root@khaled:/home/khaled#


alors j'installe le gestionnaire de version "subversion"

root@khaled:/home/khaled# apt-get install subversion
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  libapr1 libaprutil1 libsvn1
Paquets suggérés :
  subversion-tools db4.8-util
Les NOUVEAUX paquets suivants seront installés :
  libapr1 libaprutil1 libsvn1 subversion
0 mis à jour, 4 nouvellement installés, 0 à enlever et 5 non mis à jour.
Il est nécessaire de prendre 0o/1 369ko dans les archives.
Après cette opération, 3 645ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Sélection du paquet libapr1 précédemment désélectionné.
(Lecture de la base de données... 123987 fichiers et répertoires déjà installés.)
Dépaquetage de libapr1 (à partir de .../libapr1_1.4.2-3ubuntu1.1_i386.deb) ...
Sélection du paquet libaprutil1 précédemment désélectionné.
Dépaquetage de libaprutil1 (à partir de .../libaprutil1_1.3.9+dfsg-3ubuntu0.10.10.1_i386.deb) ...
Sélection du paquet libsvn1 précédemment désélectionné.
Dépaquetage de libsvn1 (à partir de .../libsvn1_1.6.12dfsg-1ubuntu1.3_i386.deb) ...
Sélection du paquet subversion précédemment désélectionné.
Dépaquetage de subversion (à partir de .../subversion_1.6.12dfsg-1ubuntu1.3_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libapr1 (1.4.2-3ubuntu1.1) ...
Paramétrage de libaprutil1 (1.3.9+dfsg-3ubuntu0.10.10.1) ...
Paramétrage de libsvn1 (1.6.12dfsg-1ubuntu1.3) ...
Paramétrage de subversion (1.6.12dfsg-1ubuntu1.3) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
root@khaled:/home/khaled#


puis je recommence la manipulation on introduisant la commande : "svnadmin create /path/to/jobeet/repository" resultat :

root@khaled:/home/khaled# svnadmin create /path/to/jobeet/repository
svnadmin: Échec de la création du dépôt
svnadmin: Impossible de créer le répertoire de niveau supérieur
svnadmin: Impossible de créer le répertoire '/path/to/jobeet/repository': Aucun fichier ou dossier de ce type
root@khaled:/home/khaled#


voila je ne comprends pas ce qui se passe !! alors que le repertoire jobeet existe belle et bien

est ce que quelqu'un peut m'aider svp ?

pour info j'ai installé le reportoir du projet jobeet comme expliquer dans le livre symfony

Cordialement

3 réponses

TychoBrahe Messages postés 1309 Date d'inscription samedi 31 janvier 2009 Statut Membre Dernière intervention 5 juin 2013 12
27 nov. 2011 à 12:05
Salut,

Regarde un peu la commande que tu as tapé :
"/path/to/jobeet/repository"
Tradution en rfançais : "/chemin/vers/le/dépot/jobeet"
C'est juste un emplacement qui n'existe pas et que tu es cencé remplacer par el véritable chemin. Bref, je te conseille de lire la documentation pour plus de détails sur l'installation de "jobeet".
0
camillagaiaschicherie Messages postés 58 Date d'inscription vendredi 23 mai 2008 Statut Membre Dernière intervention 28 février 2012
27 nov. 2011 à 13:31
bonjour,

euh... c est du php ? < TychoBrahe
0
TychoBrahe Messages postés 1309 Date d'inscription samedi 31 janvier 2009 Statut Membre Dernière intervention 5 juin 2013 12
27 nov. 2011 à 13:43
@Camilla : jobeet est une sorte de tutoriel pour symfony, qui est un framework php. Après bien sûr ce problème précis n'est pas du php, mais il y a quand même un lien.
0