Jpgraph et php problème bizarre !!!!!!!

cs_midoxe Messages postés 98 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 17 janvier 2012 - 2 nov. 2011 à 20:54
cs_midoxe Messages postés 98 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 17 janvier 2012 - 3 nov. 2011 à 10:39
Bonsoir,

je veux présenter des données par des graphes et des courbes donc j'ai opté a utiliser l'utilitaire jpgraph

pour faire simple j'ai commencer par ça :

<?php
include ("jpgraph\src\jpgraph.php");
include ("jpgraph\src\jpgraph_line.php");

$ydata = array(8,3,16,2,7,25,16);

// Creation du graphique
$graph = new Graph(300,200); 
$graph->SetScale("textlin");

// Création du système de points
$lineplot=new LinePlot($ydata);

// On rajoute les points au graphique
$graph->Add($lineplot);

// Affichage
$graph->Stroke();
?> 


quand j'exécute j'ai aucun résultat page vide même si il n y'a aucune erreur

pourquoi à votre avis les amis ce truc ne marche pas ??

Merci pour vos réponses

3 réponses

cod57 Messages postés 1654 Date d'inscription dimanche 7 septembre 2008 Statut Membre Dernière intervention 11 septembre 2013 20
3 nov. 2011 à 08:10
bonjour
slash ou antislash ?
<?php
include ("jpgraph/src/jpgraph.php");
include ("jpgraph/src/jpgraph_line.php");

//include ("jpgraph\src\jpgraph.php");
//include ("jpgraph\src\jpgraph_line.php");

$ydata = array(8,3,16,2,7,25,16);

// Creation du graphique
$graph = new Graph(300,200); 
$graph->SetScale("textlin");

// Création du système de points
$lineplot=new LinePlot($ydata);

// On rajoute les points au graphique
$graph->Add($lineplot);

// Affichage
$graph->Stroke();
?> 

Bonne programmation !
0
cs_midoxe Messages postés 98 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 17 janvier 2012 1
3 nov. 2011 à 10:30
Bonjour,

Merci pour ta réponse mais j'ai déja trouver la solution il fallait que j'installe la version du PHP 5 et non pas 4 sur le site suivant : LIEN
autre chose il ne faut surtout pas utiliser require_one au lieu de include pck ça ne marche pas

...
0
cs_midoxe Messages postés 98 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 17 janvier 2012 1
3 nov. 2011 à 10:39
Salut une autre fois,

si tu veux bien m'aider pour exploiter le résultat d'une requete qui retourne le nombre de clients a
bonnés par mois d'une table qui s'appelle TB_USER.


ca sera pas

SELECT Count * as nbr_cli, date_demar_abonnement as mois_abon from TB_USER group by

mois_abon 


par contre le problèle c'est que je dispose seulement de la date du début d'abonnement et je ne sais pas comment extraire le mois de chacun de ses dates pour le représenter sur l'histogramme..

Merci pour l'aide
0