Acceder a ma base a partir de mon .jar

30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011 - 25 oct. 2011 à 13:31
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011 - 26 oct. 2011 à 10:50
Bonjour tout le monde
J'ai fini une application qui marche bien sous eclispe apres avoir creer mon jar je ne peut pas acceder a la base mais avec l'ecipse accede bien a la base quelqu'un peut m'aideer?

11 réponses

cs_laurent1024 Messages postés 987 Date d'inscription mardi 31 mai 2005 Statut Membre Dernière intervention 30 août 2012 24
25 oct. 2011 à 14:00
Bonjour.
Quel message d'erreur tu obtiens ?
Il s'agit sans doute d'un problème de classpath ou de jar manquant.

Cdt
0
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011
25 oct. 2011 à 14:19
je ne recoi aucun message seulement si double clic sur le jar mon interface vient mais si je clic sur connection l'interface disparait
0
cs_laurent1024 Messages postés 987 Date d'inscription mardi 31 mai 2005 Statut Membre Dernière intervention 30 août 2012 24
25 oct. 2011 à 14:22
lances ton programme en passant par l'invite de commande (java -jar tonjar.jar), tu devrais avoir des messages d'erreurs qui apparaissent.

Cdt
0
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011
25 oct. 2011 à 16:46
J'ai cette erreur: Exception in thread "main" java.util.zip.ZipException: le fichier specifier est introuvable
at java.util.zip.Zipfile.open(native methode)
at java.util.zip.Zipfile.open(unknow source)
at java.util.zip.Zipfile.open(unknow source)
at java.util.zip.Zipfile.open(unknow source)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_laurent1024 Messages postés 987 Date d'inscription mardi 31 mai 2005 Statut Membre Dernière intervention 30 août 2012 24
25 oct. 2011 à 16:51
Le binaire java que tu utilises c'est le même que celui qui est configuré dans ton IDE ?
0
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011
25 oct. 2011 à 17:35
Oui c'est le meme
0
cs_laurent1024 Messages postés 987 Date d'inscription mardi 31 mai 2005 Statut Membre Dernière intervention 30 août 2012 24
25 oct. 2011 à 17:43
T'as bien un fichier manifest dans ton jar ?
0
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011
25 oct. 2011 à 18:24
Oui j'ai un fichier manifest dans mon jar
0
cs_laurent1024 Messages postés 987 Date d'inscription mardi 31 mai 2005 Statut Membre Dernière intervention 30 août 2012 24
25 oct. 2011 à 18:55
et le class-path dans le manifest est correct ?
0
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
26 oct. 2011 à 08:05
Bonjour,

Tu as continué dans un nouveau sujet sans me répondre ici : http://www.javafr.com/forum/sujet-ACCEDER-BASE-PARTIR-MON-JAR_1551165.aspx

Il y a quelque chose qui est étrange dans ce que tu fais, normalement, tout marche aisément sans avoir besoin de se tracasser.

Tu réalises une application web ou une application Swing ?
0
30kill Messages postés 17 Date d'inscription lundi 3 octobre 2011 Statut Membre Dernière intervention 26 octobre 2011
26 oct. 2011 à 10:50
Bonjour
je ne vous ai pas laisser j'ai toujour le meme probleme je vais regarder le lien apres je vous ferai signe
0