Wordnet

nounouuuuu2010 Messages postés 18 Date d'inscription samedi 2 janvier 2010 Statut Membre Dernière intervention 7 décembre 2011 - 16 oct. 2011 à 01:10
nounouuuuu2010 Messages postés 18 Date d'inscription samedi 2 janvier 2010 Statut Membre Dernière intervention 7 décembre 2011 - 5 nov. 2011 à 08:36
Bonsoir,
je veux utiliser wordnet sous Eclipse sachant que je travaille sous Ubuntu(Linux).
j'ai téléchargé le package et j'ai suivi ces instructions pour l'installation
Tapez le texte de l'url ici.
j'ai eu un problème sous eclipse :
Exception in thread "main" java.lang.NullPointerException
at didyoumean.TagFilter.Syntaxtic_Filtring(TagFilter.java:60)
at didyoumean.TagFilter.main(TagFilter.java:81)

voici le bout de code où réside le problème:
indexWord =dict.getIndexWord(((POS)POS.getAllPOS().get(h)),tag);

Est-ce que je dois utiliser un fichier xml. Et si oui d'où dois-je le télécharger?
Pouvez-vous m'aider?

2 réponses

cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
20 oct. 2011 à 14:22
Bonjour,

Dans ce cas, la première chose à faire est de te demander ce qu'est une nullPointerException et ce qui peut être susceptible de la lever.

En l'occurrence, elle ne peut pas être le fuit d'une mauvaise installation de WordNet, dans ce cas, ce sont des ClassNotFoundException qui sont levées.

Tu as donc une variables null sur laquelle tu appelles une méthode quelconque. Je ne peux pas t'en dire plus.
0
nounouuuuu2010 Messages postés 18 Date d'inscription samedi 2 janvier 2010 Statut Membre Dernière intervention 7 décembre 2011
5 nov. 2011 à 08:36
Bonjour,
La chose que m'a orientée vers penser que le problème provient d'une movaise utilisation de Wordnet sous Linux est:Le programme sur eclipse_windows marche bien.
Pouvez vous me guider pour trouver une bonne methode pour l'utilisation de wodnet sous eclipse_Linux?
0