Probleme de declaration d'un static dans la fenetre du designer

fantasio36 Messages postés 21 Date d'inscription mercredi 30 juillet 2008 Statut Membre Dernière intervention 3 octobre 2011 - 3 oct. 2011 à 11:21
NHenry Messages postés 15025 Date d'inscription vendredi 14 mars 2003 Statut Modérateur Dernière intervention 26 novembre 2022 - 3 oct. 2011 à 12:43
Salut tout le monde...une question simple....Aucun probleme pour declarer un static en mode developper sous studio2010. Par contre lorsque je fais glisser par exemple un timer de la boite a outils et que je veux le declarer en static, impossible de trouver ca dans les proprietes! On a droit qu'aux 'modifiers' "public", "protected" , etc...Du coup faut que je modifie le source genere par studio 2010 pour l'init de controls a la main... Quelqu'un pourrait il me dire s'il a deja reussi a declarer un static en mode design?
Merci.

1 réponse

NHenry Messages postés 15025 Date d'inscription vendredi 14 mars 2003 Statut Modérateur Dernière intervention 26 novembre 2022 157
3 oct. 2011 à 12:43
Bonjour,

Ton besoin n'est pas habituel, donc le concepteur n'est pas prévu pour.
Si tu veux déclarer un Timer partagé, tu peux le faire directement dans le code, sans passer par le designer.

---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS et aussi ce lien[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : )
[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés./list
---
Mon site
0