Blockage envoi emails a cause de Spams

[Résolu]
Signaler
Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
-
Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
-
Bonjour,

je travail sur une application web et la je traite l'envoie des emails de confirmation des comptes, tout marche bien jusqu'a mtn.... sauf que dès que j'envoie le messsage de confirmation de création de compte je reçois le message suivant:

550-5.0.0 Spam Detected - Mail Rejected 550-5.0.0 Please see our policy at: 550 5.0.0 http://postmaster.free.fr/#spam_detected

voici le mon code :

$destinataire = "med.midox@gmail.com";
$sujet = "Activer votre compte" ;
$entete = "From: inscription@logica.com" ;

$message='//http://127.0.0.1/logica/validation_cmpt.php?log='.urlencode($a).'&cle='.urlencode($cle).'';

mail($destinataire, $sujet, $message, $entete) ; // Envoi du mail

N.B :je rappel que je travail en local

Que dois-je faire les amis et ce ci est du a quoi au juste ?

9 réponses

Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
1
Bonjour,

Enfin, ça marche hamdolah , le nom du domaine de l'adresse de l'expéditeur était invalide alors je l'ai changer et j'ai ajouter aussi cette ligne avant la fonction d'envoi de email mail(), voici le code :

$expediteur = midoxe@domaine_valide.com; //exemple midoxe@gmail.com
ini_set('sendmail_from', $expediteur);
mail($destinataire, $sujet, $message, $entete) ;

Merci pour votre aide les amis, c'était très utile pour moi à très bientôt
Messages postés
381
Date d'inscription
lundi 12 novembre 2007
Statut
Membre
Dernière intervention
23 octobre 2014

Bonjour,

n'aurais tu pas dépassé ta limite d'envois de mail mensuel, car sur free.fr il existe une limite pour les comptes gratuits !
N'aurais tu pas également envoyé des messages MASSIVEMENT, qui pourrais être une raison de :

550-5.0.0 Spam Detected - Mail Rejected 550-5.0.0 Please see our policy at: 550 5.0.0 http://postmaster.free.fr/#spam_detected

________________________________________
( $toBe || !$toBe ) = $this->Question();
Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
1
Bonsoir,

en fait ce n'est pas du tout le cas, parce que en fait dès que je remplace:

$message='//http://127.0.0.1/logica/validation_cmpt.php?log='.urlencode($a).'&cle='.urlencode($cle).'';

par :

$message = "Bonjour tout le monde";

ça marche très bien , donc je pense pas que la cause sera le nombre de message limiter .

as-tu une autre proposition ?
Messages postés
14825
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
20 octobre 2021
157
Bonjour,

Je pencherais pour que le corps du message soit considéré comme suspect par le robot du serveur mail.

---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS et aussi ce lien[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : )
[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés./list
---
Mon site
Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
1
Bonsoir,

He viens de trouver une explication de la cause dans ce LIEN, sauf que mon email existe bien donc je ne sais pas pourquoi il a été considérer comme un spam ?

Vous avez des explications les amis ? Merci d'avance pour vos réponses
Messages postés
14825
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
20 octobre 2021
157
Bonjour,

Pour tes tests, je ne vois pas, il faudra que tu t'y fasse.

---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS et aussi ce lien[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : )
[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés./list
---
Mon site
Messages postés
98
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
17 janvier 2012
1
Bonsoir,
j'ai lu 100 fois votre règlement et je ne comprend pas qu'est ce qui vous ne va pas dans la question que je viens de poser ??
Messages postés
14825
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
20 octobre 2021
157
Bonjour,

Ce n'est pas un problème de règlement, c'est ma signature :)
Sinon, ta question dépasse mes connaissances d'où ma réponse.

v signature v
---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS et aussi ce lien[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : )
[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés./list
---
Mon site
Messages postés
9
Date d'inscription
jeudi 5 avril 2007
Statut
Membre
Dernière intervention
22 septembre 2011

Bonsoir,

Je pencherais pour que le corps du message soit considéré comme suspect par le robot du serveur mail.


Je pense comme NHenry, as tu essayé avec le lien + un petit texte explicatif ou le lien + un ipsum?
Quel est tas boîte mail?
Qu'utilise-tu comme logiciel pour tester ton script en local?
(Peut-être un problème de conf dans ton php.ini)

Pour moi le soucis viens de tas boîte mail...


++