Problème d'execution

fifaale2011 Messages postés 1 Date d'inscription jeudi 11 août 2011 Statut Membre Dernière intervention 17 septembre 2011 - 17 sept. 2011 à 14:10
Fauchmanne Messages postés 35 Date d'inscription vendredi 27 février 2009 Statut Membre Dernière intervention 26 septembre 2011 - 19 sept. 2011 à 10:23
Bonjour mes amis !
j'ai essayé de compiler mon premier Programme en Eclipse mais ça Marche plus , voila ce que me donne lorsque je compile :
java.lang.NoClassDefFoundError: com/sun/midp/main/Main
Caused by: java.lang.ClassNotFoundException: com.sun.midp.main.Main
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Exception in thread "main"
voila mon programme :
import java.*;
public class HelloWorld {

public static void main(String[ ] args)
{
System.out.println("Hello World!");
}

}

Svp une réponse !!

3 réponses

Fauchmanne Messages postés 35 Date d'inscription vendredi 27 février 2009 Statut Membre Dernière intervention 26 septembre 2011 1
17 sept. 2011 à 20:17
L'erreur parle de "Main", et ne correspond donc pas à la source fournie, qui ne contient pas d'appel à "Main". Il faut recompiler.
0
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
19 sept. 2011 à 09:00
Bonjour,

Quand tu rencontres une NoClassDefFoundError, c'est que ton build path n'est pas configuré. Tu fais un appel à une fonction qui est dans une classe que tu n'as pas dans ton build path.

L'erreur ne peut pas être levée par le code donné sauf si tu n'as pas de jre dans ton build path.

A voir ton code, je dirais que tu n'utilises pas d'ide et que tu compiles ton code à l'aide d'un javac : Quelle horreur, télécharges éclipse, il est gratos...
0
Fauchmanne Messages postés 35 Date d'inscription vendredi 27 février 2009 Statut Membre Dernière intervention 26 septembre 2011 1
19 sept. 2011 à 10:23
Ah oui, c'est à la compilation qu'il y a un soucis... donc recompiler ne marche pas, héhé
0