Problème d'envoi de mail avec indy [Résolu]

Signaler
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015
-
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015
-
Bonjour !


J'utilise le script d'envoi de mail 'mail client' de démo de la bibliothèque de composants Indy seulement l'envoi fonctionne sur certains pc mais pas sur d'autres alors que ces pc sont connectés au même routeur. Quand j'essaye d'envoyer un mail il y a un temps d'attente et j'ai les messages d'erreurs suivants
 socket error #10051
&
 socket error #10060
qui signifient tous les deux 'network unreachable' ou 'timeout ...'. J'ai déjà essayé de rallonger la propriété ReadTimeout de l'objet TidSMTP mais pas de résultat j'ai aussi desactivé mon pare feu ce qui a éffacé la première erreur...
Il semble que je ne puisse pas me connecter au serveur smpt voulu (1and1) via delphi alors qu'en utilisant thunderbird il n'y a pas de problème...


avez vous des solutions ? Des idées ?

le script est téléchargeable à cette adresse http://www.projectindy.org/DemoDownloads/Indy9Demos_26Oct04.zip



Merci pour vos rep

A+!

9 réponses

Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015

merci pour ton aide mauricio !

en fait le problème venait du port du smtp dans mon script j'avais mis 25 ça avait marché avec un seul pc va comprendre pourquoi... là je met 580 & des bananes et ça marche avec tous....
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
Salut,

je n' ai aucun problème.
je te conseille de télécharger la dernière version de Indy (pour delphi 2009 ou + récent).

A+


Composants Cindy pour Delphi
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015

ok merci Mauricio ! as tu fait le test sur plusieurs pc ? quel type de serveur smtp utilises tu ? moi c'est un smtp de 1and1 ?


je vais tester avec la version la plus récente !

@+!
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
Oui, ça fonctionne sur n' importe quel PC. Pour ce qui est de la connexion stmp, je ne connais pas les spécifités exactes ...
De toute façon, si ça marche sur un PC et pas sur un autre, ça ne doit pas être la définition smtp qui pose problème.

A+

Composants Cindy pour Delphi
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015

as tu un lienpour avoir la dernière version ? je n'a que celui là http://www.indyproject.org/downloads/Indy_9_00_14_src.zip
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015

Euh là je vais être chiant mais ... comment qu'on fait ?
il faut que je télécharge lequel j'ai choppé le zip de Indy10_4649.zip mais y a pas de packages dedans et pas de fichier bat pour tout construire tout seul


Merci !
Messages postés
165
Date d'inscription
samedi 8 mai 2010
Statut
Membre
Dernière intervention
3 janvier 2015

Ok j'pense avoir compris il faut que j'utilise tortoiseSVN pour mettre à jour automatiquement c'est génial comme truc
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
Vas sur la page que je t' ai donnée,
clique sur "ZIP" de la dernière ligne!

A+


Composants Cindy pour Delphi