Problème editeur de texte avec xml [Résolu]

Signaler
Messages postés
75
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
26 mai 2011
-
Messages postés
75
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
26 mai 2011
-
Bonjour,

J'ai créé un éditeur de texte en as3 (mon bloc texte est en saisie de texte, pour le mettre en gras je sélectionne un mot et clique sur le bouton "gras") pour pouvoir administrer en ligne un site, seulement j'ai un problème lorsque je mets un mot en gras que j'enregistre et que je recharge ma page tout le texte qui suit ce mets en gras.(mon texte est enregistré dans un xml)

Voici mon code

var formatGlobal12:TextFormat = new TextFormat ("_serif", 12);
txt_references_springbok_fr.setTextFormat (formatGlobal12);

var formatSelection12:TextFormat = new TextFormat ("_serif", 12);
formatSelection12.bold=true
formatSelection12.leading=0
function appliquerFormatSurSelection12 (e:MouseEvent):void
{
        txt_references_springbok_fr.setTextFormat (formatSelection12, txt_references_springbok_fr.selectionBeginIndex, txt_references_springbok_fr.selectionEndIndex);
}

boutonAppliquer.addEventListener (MouseEvent.CLICK, appliquerFormatSurSelection12);

1 réponse

Messages postés
75
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
26 mai 2011

Bonjour,

J'ai obtenu la réponse sur un autre forum il fallait ajouter des balise "CDATA" à mon php c'était un problème au moment de l'enregistrement