[WinDev] remplissage d'un tableau croisé avec programmation

Signaler
Messages postés
1
Date d'inscription
mardi 17 mai 2011
Statut
Membre
Dernière intervention
23 mai 2011
-
Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
-
bonjour,
je suis bloqué dans mon application pour mon projet de fin d'étude avec windev.
je veux afficher le résultat de 3 requetes dans un tableau c'est pour cela j'ai ecrit ce code

HExécuteRequête(REQ_arr_corr_union)
    HExécuteRequête(REQ_arr_corr_sum)
    HExécuteRequête(REQ_arr_panne_union)
    HExécuteRequête(REQ_arr_panne_sum)
    HExécuteRequête(REQ_arr_arret_union)
    HExécuteRequête(REQ_arr_arret_sum)

    i   est entier =0
    j   est entier =0
    k  est entier  =0

    POUR TOUT machine

       // Initialisation des compteurs entre chaque appareil

       i = 0
       j = 0
       k = 0

       // Mise en place d'un filtre pour la machine sur la requête retournant le nombre d'arrêt (je suppose)

       HFiltre(REQ_arr_arret_sum,début_prob_jour,REQ_arr_arret_sum.début_prob_jour=SAI_Saisie1 ET REQ_arr_arret_sum.des_mach=machine.des_mach)

       // Lecture du premier enregistrement
       SI HLitPremier(REQ_arr_arret_sum) ALORS
           // Enregistrement trouvé : on stocke la valeur
           i =REQ_arr_arret_sum.la_somme_Formule1
       SINON
           // pour éviter les plantages
           HErreur()
       FIN

       // Mise en place d'un filtre pour la machine sur la requête retournant le nombre de pannes (je suppose)
       HFiltre(REQ_arr_panne_sum,début_prob_jour,REQ_arr_panne_sum.début_prob_jour=SAI_Saisie1 ET REQ_arr_panne_sum.des_mach=machine.des_mach)
       SI HLitPremier(REQ_arr_panne_sum) ALORS
           j =REQ_arr_panne_sum.la_somme_Formule1   
       SINON
           HErreur()
       FIN

       // Mise en place d'un filtre pour la machine sur la requête retournant le nombre de maintenance (je suppose)
       HFiltre(REQ_arr_corr_sum,début_prob_jour,REQ_arr_corr_sum.début_prob_jour=SAI_Saisie1 ET REQ_arr_corr_sum.des_mach=machine.des_mach)
       SI HLitPremier(REQ_arr_corr_sum) ALORS
           k=REQ_arr_corr_sum.la_somme_Formule1    
       SINON
           HErreur()
       FIN

       TableAjoute(TABLE_Table2,machine.des_mach+TAB+i+TAB+j+TAB+k)   
    FIN

le résultat affiché est zéro sachant que les resuete marche bien je les ai testées et elles donnes des résultats correctes.

1 réponse

Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
74
Salut

WinDev n'étant pas du VB, tu trouveras difficilement réponse ici.

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

Le savoir est la seule matière qui s'accroit quand on la partage (Socrate)