Problème d'accent

Signaler
Messages postés
24
Date d'inscription
dimanche 6 décembre 2009
Statut
Membre
Dernière intervention
23 juin 2011
-
Messages postés
24
Date d'inscription
dimanche 6 décembre 2009
Statut
Membre
Dernière intervention
23 juin 2011
-
bonjour :)
je travaille avec wampserver ma base est de type InnoDB son interclassement utf8_unicode_ci aussi tous mes tables dans la base de la même manière quand j'entre une requête sql dont une valeur de champ contient une accent il me signe une erreur dans mysql aussi quand l'internaute entre une valeur dans un champ de texte de formulaire de mon site qui contient l'accent l'enregistrement dans la base ne se fais pas et me signale une erreur et ne fais pas la soumission !!!
existe il une solution ou un code pour que je rend ma base accepte toute les valeur de mon formulaire ou aussi saisie par moi même dans la table
Merci

4 réponses

Messages postés
1654
Date d'inscription
dimanche 7 septembre 2008
Statut
Membre
Dernière intervention
11 septembre 2013
16
bonjour
ton formulaire dans la page html ou php est il utf8 ?
je parle du charset du document
a++

Bonne programmation !
Messages postés
24
Date d'inscription
dimanche 6 décembre 2009
Statut
Membre
Dernière intervention
23 juin 2011

bonjour
oui <meta http-equiv="content-type" content="text/html; charset=UTF-8">
le probleme dans la base mysql
Messages postés
17
Date d'inscription
samedi 6 mai 2006
Statut
Membre
Dernière intervention
7 novembre 2011

Tu peux essayer en mettant ce code dans la page php qui traite ton formulaire :


header('Content-type: text/html; charset=UTF-8');
Messages postés
24
Date d'inscription
dimanche 6 décembre 2009
Statut
Membre
Dernière intervention
23 juin 2011

bonjour
dacord merci je vais essayer
a++++