Problème de connection à un server distant [Résolu]

bobarman 34 Messages postés mardi 27 avril 2004Date d'inscription 22 juin 2011 Dernière intervention - 5 mai 2011 à 12:48 - Dernière réponse : achristcolor 4 Messages postés mercredi 26 décembre 2012Date d'inscription 11 novembre 2013 Dernière intervention
- 16 nov. 2012 à 08:24
bonjour,

je n'arrive pas à me connecter à un SQL Server 2005 Express sur un pc distant via Visual Studio.

Serveur: XP Home, SQL Sever 2005 Express
Client: XP pro, Visual studio 2008, SQL server 2005

J'ai suivi le tuto de skeeky : CONNEXION DISTANTE À SQL SERVER 2005

Sur le serveur j'ai créé: une connexion sql server et une base de données
Sur le client: Outils=> connexion a une bdd => microsoft SQL server =>
Le serveur est détecté XPHOME\SQLEXPRESS
J'essaie avec Authentification Windows ou avec l'authentification SQL serveur que j'ai créée.

Dans les deux cas, ma base n'apparait pas dans: sélection base de donnée.
j'en tape une, je presse "test de connexion"
message d'erreur:
a network-related or instance-specific error occured .... bla bla ...(provider: sql network interfaces, error 28 - server doesn't support requested protocol)

Si vous connaissez le truc pour que cela marche, je suis preneur.


Clement B
Afficher la suite 

5 réponses

Répondre au sujet
alexandrevandenberghe 149 Messages postés lundi 24 décembre 2007Date d'inscription 16 juillet 2013 Dernière intervention - 5 mai 2011 à 14:21
+3
Utile
Bonjour,
Sans être sûr à 100%...

Il faut que tu configure cet acces distant sur le serveur en autorisant le protocole TCP/IP de sql server...

Sur le serveur, Tu dois avoir un "sql server configuration manager", dans cet utilitaire il y a "SQL server Network configuration"/"Protocols for XXX" (XXX c'est ton instance SQL), et dans ce sous menu il y a "TCP/IP" qu'il faut mettre à enabled.

Mais cette "astuce" est pour sql2008...

Pour sql2000, tu as un menu "sql server network utility", où il faut mettre TCP/IP en enabled...

Pour 2005, je ne sais pas, mais en cherchant un peu tu devrai trouver...
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de alexandrevandenberghe
bobarman 34 Messages postés mardi 27 avril 2004Date d'inscription 22 juin 2011 Dernière intervention - 5 mai 2011 à 15:49
0
Utile
le tcp/ip était déjà activer, néanmoins j'ai activé celui juste au dessus "named pipes" et la le message a changé:

Impossible d'ouvrir la base de données utilisateur par défaut. Échec de la connexion. Échec de la connexion de l'utilisateur...

J'ai regarder sur les site microsoft: apparemment je me suis planter quand j'ai fais ma base. Je résume les étapes et si qqun voit un truc qui va pas...

Sur le serveur dans SMSE je me log avec les identifiant Windows
clic droit sur "base de données" dans XP\SQLEXPRESS => nouvelle base
J'ajoute le nom de la base et c'est tout, OK

clic droit sur "sécurité" dans XP\SQLEXPRESS => "nouvelle connexion"
nom
authentification sql server
mot de passe
base de données par défaut: maBase

et c'est tout, il manque des choses?
J'ai vu qu'il y a un autre dossier sécurité dans la base de données, est qu'il faut y faire qqchose?


Clement B
Commenter la réponse de bobarman
alexandrevandenberghe 149 Messages postés lundi 24 décembre 2007Date d'inscription 16 juillet 2013 Dernière intervention - 5 mai 2011 à 16:16
0
Utile
Je dirai qu'il te manque le login... Tu met

authentification sql server
mot de passe
base de données par défaut: maBase

alors qu'il doit y avoir aussi l'utilisateur:

authentification sql server
login
mot de passe
base de données par défaut: maBase
Commenter la réponse de alexandrevandenberghe
bobarman 34 Messages postés mardi 27 avril 2004Date d'inscription 22 juin 2011 Dernière intervention - 5 mai 2011 à 16:36
0
Utile
C'est bon ca marche!!
C'était bien un problème d'utilisateur

Ce qu'il n'allait pas:
J'avais d'abord créé ma base avant ma connexion, elle n'était pas liées.

Je m'en suis sorti:
J'ai supprimé la base, pour en recréer une derrière en notant ma SQL connexion comme propriétaire.
Puis dans les propriétés de ma connexion: sur mappage était coché maBase et sur "role du serveur" j'ai coché adminbulk

Le tuto : SÉCURITÉ SQL SERVER m'a un peu guidé mais il faudrait vraiment un tuto sur les connexions distantes.

Merci à alex

Clement B
Commenter la réponse de bobarman
achristcolor 4 Messages postés mercredi 26 décembre 2012Date d'inscription 11 novembre 2013 Dernière intervention - 16 nov. 2012 à 08:24
0
Utile
Problème de connexion à sql serveur 2000
Site (A) avec son serveur
Site(B) distant à des kilomètres avec son serveur.
Problème de connexion de site A vers B avec mon application cliente.
Commenter la réponse de achristcolor

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.