Sous-domaines

Signaler
Messages postés
38
Date d'inscription
mercredi 14 avril 2010
Statut
Membre
Dernière intervention
2 septembre 2011
-
Messages postés
38
Date d'inscription
mercredi 14 avril 2010
Statut
Membre
Dernière intervention
2 septembre 2011
-
Salut à tous,
problème certainement déjà largement commenté mais je n'ai pas trouvé de soluce...
J'ai un domaine "mondomaine.com" sur un serveur semi-dédié chez 1&1.
J'ai crée un sous-domaine "mon-sous-domaine.mondomaine.com".
Jusque la pas de souci, j'ai mes nouveaux accès ftp qui pointent bien sur le dossier mondomaine.com/subdomains/mon-sous-domaine.
Le souci est que lorsque je veux accéder à mon-sous-domaine en tapant http://www.mon-sous-somaine.mondomaine.com, cela ne pointe pas vers le dossier mondomaine.com/subdomains/mon-sous-domaine.
En fouilant un peu, j'ai vu des histoires de modifs d'htaccess ou de http.conf ou de vhost.conf mais rien n'y fait, toujours la page "default parallels plesk panel page".

Si quelqu'un a une idée, ce serait cool!
Merci d'avance pour vos réponse!

2 réponses

Messages postés
1309
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
5 juin 2013
12
Salut,

En effet il te faut gérer ça avec les virtualhost d'apache. Ne te fixe pas sur certains fichiers genre .htaccess, httpd.conf, apache2.conf ou vhost.conf, mais regarde comment c'est organisé sur ce serveur précis (tout le monde arrange la conf comme bon lui semble et on trouve des choses très différentes d'un serveur à l'autre).

Un petit exemple d'hôtes virtuels en tout condensé :
NameVirtualHost *:80
<VirtualHost *:80>
        ServerName example.org
        ServerAlias www.example.org
        ServerAdmin webmaster@example.org

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>

<VirtualHost *:80>
        ServerName toto.example.org
        ServerAlias www.toto.example.org
        ServerAdmin toto@example.org

        DocumentRoot /home/toto/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/toto/www/>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>

(je sais, j'ai mis la coloration syntaxique du xml alors que ça n'en est pas, mais avec "autre" les pseudo-balises sautent)
Messages postés
38
Date d'inscription
mercredi 14 avril 2010
Statut
Membre
Dernière intervention
2 septembre 2011

Merci beaucoup,
je regarde ça ce soir!!!