Création d'un bouton simple par code - problème [Résolu]

Signaler
Messages postés
186
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
28 avril 2011
-
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
-
Bonjour,
Je suis face à un problème tout con : Je veux créer un bouton par code mais le bouton ne s'affiche pas !
Pourtant il n'y a pas d'erreur vous pouvez vérifier :

procedure TForm1.FormCreate(Sender: TObject);
var
Button1:TButton;
begin
Button1:=TButton.create(Self);
Button1.left:=20;
Button1.Caption:='Button1';
Button1.Visible:=true;
end;


Ou bien ai-je oublié quelque chose (^_^)

Merci de m'aider !

5 réponses

Messages postés
3818
Date d'inscription
vendredi 23 juillet 2004
Statut
Modérateur
Dernière intervention
18 septembre 2020
34
Hi,

en clair :
Button1.Parent := Form1;



[hr]@+Cirec
[hr]
Messages postés
2527
Date d'inscription
jeudi 15 janvier 2004
Statut
Membre
Dernière intervention
16 octobre 2019
14
Salut,

« C'était un pôv bouton qui s'appelait Button1
« L'avait pas d'papa, l'avait pas d'maman* ! »


* de parent

_______________________________________
Soutenez Wikimédia France aujourd'hui : http://dons.wikimedia.fr
Messages postés
186
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
28 avril 2011

Merci
Messages postés
2527
Date d'inscription
jeudi 15 janvier 2004
Statut
Membre
Dernière intervention
16 octobre 2019
14
La poésie restera donc toujours le parent pauvre de delphifr...




_______________________________________
Soutenez Wikimédia France aujourd'hui : http://dons.wikimedia.fr
Messages postés
2106
Date d'inscription
mardi 10 décembre 2002
Statut
Modérateur
Dernière intervention
15 décembre 2014
5
Salut,

"L'avait pas d'papa"

On peut quand même dire qu' il l' a mis sur la bonne voie!
On pourrait commencer à répondre aux questions en faisant une sorte de jeu de piste

Il y en a bien qui dans leur question, donnent la solution alors ...

A+


Composants Cindy pour Delphi