Activer/désactiver une fonction Excel dans un seul feuil

Signaler
Messages postés
113
Date d'inscription
mardi 14 septembre 2010
Statut
Membre
Dernière intervention
26 octobre 2014
-
jordane45
Messages postés
27333
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
23 janvier 2020
-
Bonjour,

J'ai un tableau (A1 :K166) dans la feuil TABLE
Dans la feuil RECAP j'utilise les fonctions sommeprod qui concerne mon tableau

Lorsque j'ajoute ou je supprime des informations dans mon tableau feuil table mon micro est devenu très lent alors j'ai constaté que les fonctions sommeprod sur feuil recap est la cause

Question :
SVP comment désactiver les fonctions dans la feuil recap et les activés au moment que je veux uniquement dans la feuil recap. (soit avec Excel ou vba)

j'ai pensé d'ajouter un Apostrophe ( ' ) avant les fonctions
'=SOMMEPROD((TABLE!$A$2:$A$200>=$B$3)*(TABLE!$A$2:$A$200<=$B$4)*(TABLE!$B$2:$B$200="MOMO")*TABLE!C$2:C$200)
et j'ai pensé aussi de changé le nom de la feuil dans la fonction
SOMMEPROD((feuil3!$A$2:$A$200>$B$3)*(feuil3!$A$2:$A$200<=$B$4)*(feuil3!$B$2:$B$200="MOMO")*feuil3!C$2:C$200)
est ce que je peux faire ça avec un code
http://www.cijoint.fr/cjlink.php?file=cj201101/cij7Nv3gRS.xls

1 réponse

Messages postés
27333
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
23 janvier 2020
322
Bonjour,
regardes du cote de :
Application.enable events ( = true ou false selon le besoin).
Cherches aussi du cote de application.calculate ( auto ou manuel) pour desactiver le calcul sur ta feuille au moment de la macro.

Cordialement,
Jordane,
______________________________________________________
Règles du forum à lire avant de poster une question : ICI