IIS 7 sur Windows 2008 - Problème installation PHP 4 [Résolu]

Signaler
Messages postés
90
Date d'inscription
mercredi 11 juin 2003
Statut
Membre
Dernière intervention
3 février 2011
-
Messages postés
90
Date d'inscription
mercredi 11 juin 2003
Statut
Membre
Dernière intervention
3 février 2011
-
Bonjour à tous,

j'ai besoin d'installer PHP 4 sur IIS 7 (windows server 2008 x32).
J'ai passé la journée d'hier à tester tout ce que j'avais pu trouver sur le net, à la fois dans la procédure d'install du dossier PHP et sur la configuration du mapping, etc dans IIS 7.
Je souhaite utiliser ISAPI.
Dans le doute j'ai testé les deux dll (php4sapi.dll et php4ts.dll, la seconde générant moins d'erreur dans les logs) dans le répertoire SAPI ou à la racine du dossier PHP (que j'ai placé sous C:/).

J'ai testé l'install d'un php.ini sous c:/windows ou c:/PHP.
Dans les deux cas, j'ai déclaré PHP dans le path de la machine.


J'ai même repris l'installation totale de PHP plusieurs fois, histoire d'être sûre de pas mélanger les interventions.

Rien n'y fait.

Même une simple page test.php sans rien dedans n'est pas consultable et renvoi un code erreur du type 500.

Je craque.

Quelqu'un aurait il une info, une piste ?

Merci d'avance


Lawra C.

6 réponses

Messages postés
90
Date d'inscription
mercredi 11 juin 2003
Statut
Membre
Dernière intervention
3 février 2011

Alors, je fais un retour, et donc en fait, j'ai abandonné PHP 4 et je suis passé à PHP 5 ce qui a été bien bien bien plus simple.

Par contre, ça devait être le retour des fêtes, je ne sais pas pourquoi j'insistais pour rester à la version 4.

Ca ce s'est quand même pas fait tout seul, mais après un peu de ménage des dans les dll, ça fonctionne correctement.

Merci à tous pour votre aide!


Lawra C.
Messages postés
1309
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
5 juin 2013
12
Salut,

Déjà tu devrais commencer par installer une version à jour de PHP, actuellement les deux branches stables et maintenues sont les branches 5.2 (5.2.16 pour la dernière version stable) et 5.3 (5.3.4 pour la dernière version stable). Actuellement le support de PHP 4 est totalement terminé et, si on ne veux pas se tirer une balle dans le pied, il faut passer à PHP 5.
Messages postés
2381
Date d'inscription
lundi 4 février 2002
Statut
Membre
Dernière intervention
29 décembre 2012
12
Je peux comprendre son problème. Hélas il m'arrive souvent de faire des audits sur PHP4 pour des clients qui ne voient pas l'utilité de passer en 5. N'oublions pas de la rétro-compatibilité n'est pas assuré à 100% hélas.
De mon coté, je crée une Virtual machine sous 2003, voire XP.
S.
Messages postés
90
Date d'inscription
mercredi 11 juin 2003
Statut
Membre
Dernière intervention
3 février 2011

Oui, c'est exactement le problème : je n'ai pas le choix dans la version de PHP et encore moins celle du serveur (j'ai essayé de leur faire comprendre qu'une solution wampserver serait teeeellement plus simple).

Il n'empêche que j'ai vu sur pas mal de forum que même php5 posait problème sur IIS 7


Lawra C.
Messages postés
2381
Date d'inscription
lundi 4 février 2002
Statut
Membre
Dernière intervention
29 décembre 2012
12
Bizarre, je n'ai pas remarqué de problème pour PHP5/IIS7.
Quant à la solution WAMPServer, navré de dire que ce n'est pas une solution de production.
Tu as vu ce lien ? http://www.php.net/manual/en/install.windows.iis7.php
Tiens nous au courant.
S.
Messages postés
90
Date d'inscription
mercredi 11 juin 2003
Statut
Membre
Dernière intervention
3 février 2011

Je crois que dans le cas de PHP 4 il s'agit du php.exe
J'avais essayé cette piste, mais je n'avais pas toutes ces infos sur le paramétrage CGI dans le php.ini.

Merci !

Je donne des nouvelles dès que j'aurai pu l'essayer.

Lawra C.