Problème avec FormulaArray [Résolu]

Signaler
Messages postés
12
Date d'inscription
jeudi 3 juin 2010
Statut
Membre
Dernière intervention
18 octobre 2013
-
Messages postés
12
Date d'inscription
jeudi 3 juin 2010
Statut
Membre
Dernière intervention
18 octobre 2013
-
Bonsoir.
J'ai un classeur de 13 feuilles dont 12 réservées pour les mois et une pour la sommation.Lorsque je saisis les formules dans les cellules tout fonctionne.Exemple:
{=SOMME(SI(Janv!$C$7:$C$85="Ch1";$E$7:$E$85))}

Comme il y a plus de 1000 cellules a saisir je souhaite utiliser le code suivant pour me faciliter la tâche. J'utilise des valeurs différentes comme 7010 ou chaine "Ch1".
Pour la valeur 7010 ça fonctionne, mais pour "Ch1" j'ai un message d'erreur 1004.J'ai donc essayé de mettre des doubles ""Ch1"" mais rien ne change

Dim i As Long
  For i = 1 To 12
      Cells(i + 7, 7).FormulaArray = _
"=SUM(IF(" & Sheets(i + 8).Name & "!R7C3:R85C3=" & 7010 & "," & Sheets(i + 8).Name & "!R7C5:R85C5))"
  Next i



Dim i As Long  For i = 1 To 12
        Cells(i + 7, 7).FormulaArray = _
      "=SUM(IF(" & Sheets(i + 8).Name & "!R7C4:R85C4=" & "Ch1" & "," & Sheets(i + 8).Name & "!R7C5:R85C5))"  Next i

Si vous avez la solution, je vous remercie d'avance.

2 réponses

Messages postés
29635
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
30 septembre 2020
337
Bonjour,
écrit ton 'ch1' comme ceci : """ch1"""

Cordialement,
Jordane,
______________________________________________________
Règles du forum à lire avant de poster une question : ICI
Messages postés
12
Date d'inscription
jeudi 3 juin 2010
Statut
Membre
Dernière intervention
18 octobre 2013

Bonjour Jordane.
Je te remercie vivement pour ta réponse qui a résolu mon problème et pourtant j'ai cherché dans les forums mais en vain.
Encore un grand merci.