Phpmyadmin sur base distante

biker63490 Messages postés 1 Date d'inscription mercredi 1 octobre 2003 Statut Membre Dernière intervention 1 octobre 2003 - 1 oct. 2003 à 15:04
witebs Messages postés 3 Date d'inscription jeudi 11 septembre 2003 Statut Membre Dernière intervention 7 juillet 2005 - 3 oct. 2003 à 17:52
Bonjour
Je viens d'installer easy PHP 1.6 sur ma machine et sur le serveur.
J'aimerai gérer les bases qui se trouve sur le serveur depuis ma machine.

J'ai donc modifié mon config.inc.php comme suit :
host : nomduserveur
user : login d'ouverture de session du serveur
password : mot de passe d'ouverture de session du serveur

PB : quand je tape http://127.0.0.1/mysql je suis en localhost
quand je tape http://nomduserveur/mysql : je tombe sur une page d'erreur.
Ou est le problème ???

merci

mecanique moto customs et concentres : www.freebiker.net

3 réponses

Magicking Messages postés 195 Date d'inscription vendredi 13 octobre 2000 Statut Membre Dernière intervention 8 juillet 2004
1 oct. 2003 à 15:45
C'est quoi le type d'erreur ou numero mais apparament depuis la 1.6 on ne peut acceder a ce repertoire que en locale pour y remedier tu dois chercher ces lignes dans le fichier httpd.conf qui se trouve dans le dossier EasyPHP/apache/conf/

Alias /mysql/ "D:/EasyPHP/phpmyadmin/"

<Directory "D:/EasyPHP/phpmyadmin">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
deny from all
</Directory>

Alias /home/ "D:/EasyPHP/home/"

<Directory "D:/EasyPHP/phpmyadmin">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
deny from all
</Directory>

La ligne Order deny,allow definie dans quelle ordre il doit utiliser les priorité
allow from 127.0.0.1
deny from all
Dit que toutes les connexions autre que venant de localhost sont rejeté pour y remedier tu peut faire allow from all et placer un # devant le deny ou le supprimer...

je tiens a te faire remarquer que il y'a une erreur dans la ligne en dessous de Alias /home/ "D:/EasyPHP/home/" il faut remplacer "D:/EasyPHP/phpmyadmin" par "D:/EasyPHP/home" sinon tout le monde pourra ajouter des alias et allé sur tes(on) disque(s)
0
Magicking Messages postés 195 Date d'inscription vendredi 13 octobre 2000 Statut Membre Dernière intervention 8 juillet 2004
1 oct. 2003 à 15:46
J'ais oublié y'a D:/EasyPHP mais sa correspond juste a mon dossier d'installe de EasyPHP enfin je pense que tu as compris
0
witebs Messages postés 3 Date d'inscription jeudi 11 septembre 2003 Statut Membre Dernière intervention 7 juillet 2005
3 oct. 2003 à 17:52
@> Magicking
je n'ai que 2 mots a dire: mer ci

;))
0
Rejoignez-nous