Compilation d'un programme C++ qui utilise glut avec Intel fortran

cs_oswa Messages postés 7 Date d'inscription jeudi 25 février 2010 Statut Membre Dernière intervention 6 décembre 2010 - 1 sept. 2010 à 09:55
cs_rt15 Messages postés 3874 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 7 novembre 2014 - 2 sept. 2010 à 15:08
Bonjour,
Je fais un programmme C++ qui utilise la lib glut, et lorsque je le compile avec Intel Fortran ( j'ai mis les fichiers de opengl dans le repertoire de travail), je trouve des erreurs telque

ExCarre.obj : error LNK2019: unresolved external symbol glutInit referenced in function main
VBATCH00.exe : fatal error LNK1120: 18 unresolved external

SVP est-ce-que vous pouvez m'aider pour que je peux compiler mon programme avec Intel fortran ?

5 réponses

cs_rt15 Messages postés 3874 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 7 novembre 2014 13
1 sept. 2010 à 12:07
Salut,

Fortran est un langage. Tu as peut être les compilos C++ et Fortran Intel, mais je ne penses pas que tu compiles avec "Intel Fortran".

Il faut que tu mettes glut32.lib en entrée du lieur. -lglut32 si le compilo intel fait comme tout le monde (Et il y a des chances).
0
cs_oswa Messages postés 7 Date d'inscription jeudi 25 février 2010 Statut Membre Dernière intervention 6 décembre 2010
1 sept. 2010 à 13:24
merci rt15 pour la réponse.
oui j'utilise fortran intel dans la compilation en effet j'ai tous les fichier .lib , .dll et .h necessaire pour opengl dans mon repetoire de travail mais sans resultat.
pardonnez je n'ai pas vous compris par "en entrée du lieur. -lglut32"
0
cs_rt15 Messages postés 3874 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 7 novembre 2014 13
1 sept. 2010 à 17:52
Tout mettre dans le répertoire de travail ne sert qu'à faire un gros fouillis. Il est préférable d'utiliser des options de compilation correctement (-I pour les répertoires des .h, -L pour les répertoires des .lib, -l pour les .lib).

Ton lieur ne trouve pas des symboles définis dans glut32.lib. Si tu ne lui dit pas de prendre en considération glut32.lib, il ne peut pas deviner qu'ils sont dedans. Il faut que tu ajoutes -lglut32 dans ta ligne de link d'une manière ou d'une autre. Ca devrait ressembler à ce genre de chose ta compile :

gcc test.c -o test.exe -Lc:\glut\lib -Ic:\glut\include -lglut32
0
cs_oswa Messages postés 7 Date d'inscription jeudi 25 février 2010 Statut Membre Dernière intervention 6 décembre 2010
2 sept. 2010 à 14:44
merci rt15 pour votre reponse clair.
je veux avoir comment je peux inclure mes lib et mes include dans la ligne de link dans le compilateur Intel Fortran?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_rt15 Messages postés 3874 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 7 novembre 2014 13
2 sept. 2010 à 15:08
Bin c'est assez standard. -l, comme je te le disais.
0
Rejoignez-nous