Excel (VBA) aggreger des collones

Signaler
Messages postés
12
Date d'inscription
lundi 7 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010
-
Messages postés
12
Date d'inscription
lundi 7 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010
-
Bonjour a tous,
je suis assez debutant sous excel vbavoila alors j ai le tableau suivant:
share day share month
Monday 6 January 6.3
Tuesday 1.5 February 9.5
Wednesday 3 March 9.4
Thursday 6 April 8
Friday 9 May 6
Saturday 7 June 7
Sunday 8 July 6.8
August 6.3
September 9
October 8
November 2
December 8

Je voudrai pouvoir construire un tableau a deux colonne seulement avec l ensemble des jours de l annee dans une colonne et dans l autre le produit des nombres correspondant .( par exemple le peremier lundi du moi de janvier sera 6*6.3 et ainsi de suite pour les 365 jours de l annee...
Je vois pas trop comment utiliser le if(...) ici...

Merci d avance
et bonne journee

3 réponses

Messages postés
797
Date d'inscription
mardi 7 juin 2005
Statut
Membre
Dernière intervention
23 février 2011
7
Tu peux le faire directement en EXCEL, pas besoin de VBA pour ça.

Un tableau pour les jours sur 2 colonnes (1 pour lundi, 2 pour mardi, ...) :
A1: 1 B1: 6
A2: 2 B2: 1.5
...
Zone de Nom : Jours

Un tableau sur 2 colonnes (1 pour janvier, 2 pour février, ...):
C1: 1 D1: 6.3
C2: 2 D2: 9.5
...
Zone de Nom : Mois

Ensuite, tu crées ton tableau de date :
E1: 01/01/2010
E2: 02/01/2010
...
Tu fais glisser ton curseur et tu crées les 365 lignes de ton calendrier.

Une formule pour faire ton calcul:
F1:=RECHERCHEV(JOURSEM(E1;2);Jours;2;FAUX)*RECHERCHEV(MOIS(E1);Mois;2;FAUX)

Plus qu'à copier ta formule partout (double-clic).
Et voilà, tu as ton résultat en 2mn chrono.

Molenn
Messages postés
12
Date d'inscription
lundi 7 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010

Merci pour ta reponse, c est excatement ce qu il me faut. Par contre dans mon problem de base j ai non pas 365 valeures mais 8760 (car je veux un decoupage par heures sur l annee... avec un format du genre: hh jj/mm/aaaa) et j arrive a appliquer ta methode pour ce format.
Mais par contre je n arrive pas sous excel a faire la serie de nombre hh jj/mm/aaaa en faisant glisser le curseur pour creer une colonne avec les 8760 valeures, comme je le faisais pour cree 365 jours de l annee quand j avais le format jj/mm/aaaa.
Saurais tu comment je peux faire??

merci d avance
legot
Messages postés
12
Date d'inscription
lundi 7 juin 2010
Statut
Membre
Dernière intervention
25 juin 2010

C est bon j ai resolu le probleme, c etait un probleme de format de mes cellules... ca marche parfaitement. encore merci