Probléme avec script de sauvegarde base de données

Signaler
Messages postés
97
Date d'inscription
lundi 17 décembre 2001
Statut
Membre
Dernière intervention
7 août 2015
-
Messages postés
97
Date d'inscription
lundi 17 décembre 2001
Statut
Membre
Dernière intervention
7 août 2015
-
Bonjour,
j'essai de mettre en place sur mon site internet un system de sauvegarde de ma base de données. J'ai donc suivi le script lien.
J'ai saisi mes infos de connexion sql et ftp mais lorsque j'execute le code je tombe sur une page blache et je n'ai aucunes sauvegarde de faites (mail ou ftp...)
Savez vous qu'elle probleme il pourait y avoir ?

au niveau du code j'ai juste modifié cette partie :

	const Producteur_nom = "1030";
const Producteur_commentaire = "Sauvegarde de la base de données du site";
const Producteur_HTTP = "www.monsite.com";
const Producteur_email = "contact@monsite.fr";
const Producteur_version = "1.0";

private $sql_export = "";
private $ini = array();

public function __construct($db,$host="",$user="",$pass="") {
$this->ini["db_host"] = !empty($host) ? $host : "mon acces";
$this->ini["db_user"] = !empty($user) ? $user : "mon nom utilisateur";
$this->ini["db_pass"] = !empty($pass) ? $pass : "mon mot de passe";
$this->ini["db_name"] = $db;

$this->ini["email_adresse"] = "contact@monsite.fr";

$this->ini["ftp_url"] = "ftp.monsite.fr";
$this->ini["ftp_login"] = "mon login";
$this->ini["ftp_pass"] = "mon mot de passe";




Merci pour votre aide.

2 réponses

Messages postés
255
Date d'inscription
vendredi 20 avril 2007
Statut
Membre
Dernière intervention
9 août 2013
4
Il y a surement eu une erreur de connexion a la base qui n'apparait pas, rajoutes error_reporting(E_ALL); au debut de ton script ou regardes dans les logs php de ton serveur ca permettra de savoir un peu plus ce qui ce passe.
Messages postés
97
Date d'inscription
lundi 17 décembre 2001
Statut
Membre
Dernière intervention
7 août 2015

merci j'ai trouvé le truc. il faut jsute en fin de script si l'on veut recevoir par mail enlever les //

du coup je recoi bien un mail avec le fichier .sql mais :

en Expediteur j'ai : en nom Producteur_nom et en mail (celui de l'hebergeur)
en objet j'ai : Producteur_commentaire le 11/05/2010

j'ai pourtant bien renseigner les valeurs en debut de script.