Envoye automatique de mail avec Microsoft Outlook

lamalicefrlet Messages postés 3 Date d'inscription samedi 17 mars 2007 Statut Membre Dernière intervention 24 mars 2010 - 24 mars 2010 à 09:05
lamalicefrlet Messages postés 3 Date d'inscription samedi 17 mars 2007 Statut Membre Dernière intervention 24 mars 2010 - 24 mars 2010 à 12:56
Bonjour à tous.

Avant la question, les "pré-requis":

1°-Je suis utilisateur d'Excel sur un poste bureautique, mais je ne suis pas administrateur du poste.
2°- Il est inconcevable que l'administrateur me donne des "pouvoirs" pour résoudre le problème suivant.

La question:
J'avais développé un fichier Excel avec une routine en VBA me permettant d'expédier automatiquement ce fichier à date prédefinie (tous les lundi, via Microsoft Outlook.
Suite à un changement de matériel, cette routine m'ouvre maintenant systématiquement Outlook Express, qui ne peut-être utilisé sur mon poste.
Quelqu'un peut-il m'expliquer comment avoir Microsoft Outlook en ouverture par défault et non Express.

Voici ma Sub:
---------------------------------------
Sub fermer()
ActiveWorkbook().Save
j = Weekday(Date, 2) ' 1 Lundi, 2 Mardi, 3 Mercredi ...

If j 1 Then ' 5 vendredi, 6 = Samedi
crlf = Chr(10) + Chr(13)

ActiveWorkbook.SendMail Recipients:="prenom.Nom@serveur.fr"

MsgBox ("fichier envoyé.")

End If

ActiveWorkbook().Close

End Sub
---------------------------------------

Merci d'avance pour votre aide.

D.Lamalice

4 réponses

cs_pacadebord Messages postés 113 Date d'inscription lundi 31 mars 2003 Statut Membre Dernière intervention 19 décembre 2011 2
24 mars 2010 à 10:16
Bonjour,

Mais quel est donc l'OS de vos nouveaux postes ?

Pac
0
cs_pacadebord Messages postés 113 Date d'inscription lundi 31 mars 2003 Statut Membre Dernière intervention 19 décembre 2011 2
24 mars 2010 à 10:30
Sur 2000 et XP il y a bouton Démarrer, "Configurer les programmes par défaut"...

Pac
0
lamalicefrlet Messages postés 3 Date d'inscription samedi 17 mars 2007 Statut Membre Dernière intervention 24 mars 2010
24 mars 2010 à 12:41
Bonjour et merci pour la réponse.
C'est vrai, j'ai "un peu oublié" de dire que c'était sur Windows XP Pro, en réseau.
Mais comme je suis sur XP au bureau et sur Mac OSX.6 à la maison, il m'arrive de me faire des noeuds
Je vais essayé dès cet APM de voir ça avec la config des programmes, car là je vais partir bosser.

Encore merci, et je reviens pour le suivi d'infos.

D.Lamalice
0
lamalicefrlet Messages postés 3 Date d'inscription samedi 17 mars 2007 Statut Membre Dernière intervention 24 mars 2010
24 mars 2010 à 12:56
Décidément, j'ai la RAM ( la la mienne) qui rame !
XP Pro et Microsoft Outlook 2003 ...

D.Lamalice
0
Rejoignez-nous