Remplacer ereg_replace par preg_replace [Résolu]

cs_Krasha 36 Messages postés mardi 25 septembre 2007Date d'inscription 29 mars 2010 Dernière intervention - 18 mars 2010 à 01:31 - Dernière réponse : cs_Krasha 36 Messages postés mardi 25 septembre 2007Date d'inscription 29 mars 2010 Dernière intervention
- 21 mars 2010 à 05:54
Bonjour à tous,

J'essaie actuellement d'intégrer un petit module de sondage sur un site et je me retrouve confronté à une petite erreur que je n'arrive pas à réparer.

L'erreur affichée est : Deprecated: Function ereg_replace() is deprecated in C:\wamp\www\monsite\class_poll.php on line 114
Ce qui est normal vu que la fonction ereg_replace est obsolète. Je tente donc de la remplacer par la fonction preg_replace qui semble plus appropriée mais je dois faire une erreur dans la syntaxe.

Voici ma ligne de base:

if (ereg("^3.",PHP_VERSION) || ereg("^4.0",PHP_VERSION)) {
    abort("This script requires PHP 4.1 or higher!" );
}


et voici après modification :

if (preg_replace("/^3./",PHP_VERSION) || preg_replace("/^4.0/",PHP_VERSION)) {
    abort("This script requires PHP 4.1 or higher!" );
}


Voyez vous où j'ai fait une erreur?
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
TychoBrahe 1310 Messages postés samedi 31 janvier 2009Date d'inscription 5 juin 2013 Dernière intervention - 18 mars 2010 à 10:35
3
Merci
Saut,

Soit dit en passant, tu peux carrément virer ce test. Non seulement tu n'en a rien à faire de tester automatiquement ta version de PHP vu que tu sais déjà laquelle tu as, mais en plus ça fait environ 10 ans que PHP 3 est obsolète.

Merci TychoBrahe 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 93 internautes ce mois-ci

Commenter la réponse de TychoBrahe
kohntark 3708 Messages postés lundi 5 juillet 2004Date d'inscription 27 avril 2012 Dernière intervention - 18 mars 2010 à 08:11
0
Merci
Salut Krasha,

L'"équivalent" de ereg est preg_match, pas preg_replace !!

Mais utiliser une regex pour faire ça est un peu inutile.
Tu pourrais simplement faire :
<?php
if (version_compare(PHP_VERSION, '4.1.0') == -1) abort("This script requires PHP 4.1 or higher!" );
?>


Cordialement,



Kohntark -
Commenter la réponse de kohntark
cs_Krasha 36 Messages postés mardi 25 septembre 2007Date d'inscription 29 mars 2010 Dernière intervention - 21 mars 2010 à 05:54
0
Merci
Comme dirait le seigneur Dagonet : "C'est pas faux!"

J'ai viré le test
Commenter la réponse de cs_Krasha

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.