Apparition de balises HTML après màj de ma bdd

Signaler
Messages postés
2
Date d'inscription
vendredi 29 janvier 2010
Statut
Membre
Dernière intervention
1 mars 2010
-
Messages postés
2
Date d'inscription
vendredi 29 janvier 2010
Statut
Membre
Dernière intervention
1 mars 2010
-
Bonjour à tous,
Je rencontre un problème lié à la mise à jour de ma base de donnée via une plateforme administrateur. Tout se passe correctement si ce n'est que lorsque j'applique un enrichissement typographique dans un textarea grâce à Tiny MCE via ma plateforme admin, la mise à jour des textes se fait correctement mais l'enrichissement typographique se traduit par l'apparition de balises HTML.
Dans ma base de donnée tous les éléments sont en "utf8_unicode_ci" et pourtant ça bug.
J'ai effectué la sécurisation des textarea avec "htmlspecialchars(stripslashes".

Pourriez-vous m'éclairer quant à ce problème qui reste mystérieux pour moi. Merci d'avance pour les infos.
Artmaniak
Le sens de la vie c'est justement de s'amuser avec la vie.
KUNDERA Milan

3 réponses

Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
30
Salut,

Désolé mais je n'ai rien compris; que tu te retrouves avec des balises HTML dans ta DB semble normal avec l'utilisation de tiny MCE, non ?
Peux tu être plus précis ?

Cordialement,

Kohntark -
Messages postés
197
Date d'inscription
mardi 20 janvier 2004
Statut
Membre
Dernière intervention
20 février 2013
1
Bonsoir,

voir la doc de htmlspecialchars sur php.net ( lien )

tu peux jeter un coup d'oeil sur HTMLPurifier ( lien )

bonne soirée
Messages postés
2
Date d'inscription
vendredi 29 janvier 2010
Statut
Membre
Dernière intervention
1 mars 2010

Merci pour les infos.
J'ai réussi à solutionner mon p'tit problème grâce à vos indications et un peu plus d'attention.
Cordialement
Artmaniak


Le sens de la vie c'est justement de s'amuser avec la vie.
KUNDERA Milan