Pb chargement via LoadVars()

[Résolu]
Signaler
Messages postés
18
Date d'inscription
lundi 27 janvier 2003
Statut
Membre
Dernière intervention
23 février 2010
-
Messages postés
18
Date d'inscription
lundi 27 janvier 2003
Statut
Membre
Dernière intervention
23 février 2010
-
Bonjour,

J'ai un problème pour l'initialisation de chargement de variables via LoadVars().

Je veux attribuer ma variable dans un champ text dynamique, ce texte dynamique s'anime. Et je dois initialiser le texte de ce champ avant que l'anim commence.

Mais le OnLoad de ma LoadVars n'est appelé qu'après l'initialisation du script qui anime mon champ text dynamique.

Ma question :

Comment charger ma variable (le LoadVars.OnLoad) avant le script de l'anime du champ texte ?

a+

4 réponses

Messages postés
18
Date d'inscription
lundi 27 janvier 2003
Statut
Membre
Dernière intervention
23 février 2010

Bonjour,

Merci pour vos aides, j'ai trouvé la solution, en fait j'ai créer un frame vide avant tout et j'ai déplacer mon code et là ça fonctionne.

a+
Messages postés
1313
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
20 juin 2014
6
Salut,

et bien il faut que tu appelles ta fonction LoadVars avant le script de ton anim.

BBFUNK01
Messages postés
292
Date d'inscription
mercredi 7 novembre 2007
Statut
Membre
Dernière intervention
15 janvier 2013
3
Salut;
Et tu n'as pas moyen de lancer cette animation avec l'événement onLoad?
Messages postés
1313
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
20 juin 2014
6
Hello,

peux-tu mettre ton code dans ton post stp ? Ce sera plus facile pour voir où ça coince :)

BBFUNK01