Probleme requete vide

andy331 Messages postés 45 Date d'inscription mercredi 11 novembre 2009 Statut Membre Dernière intervention 11 juin 2010 - 4 févr. 2010 à 11:42
crn_c21 Messages postés 302 Date d'inscription samedi 24 janvier 2004 Statut Membre Dernière intervention 4 février 2011 - 20 févr. 2010 à 23:50
Bonjour tout le monde!!
Voila j'ai un problème de requête!!

J'ai deux table T_ville et T_code_postal et deux liste déroulante Modifville et Modifcodepostal

pour faire fonctionner mes requête je vais sur ma liste Modifcodepostal propriété, donnée puis contenu et je coller ma requête
Select DISTINCT T_Code_postal.ID_code_postal, T_Code_postal.code_postal_code FROM T_Code_postal Inner Join T_ville On T_Code_postal.ID_code_postal = T_ville.ID_ville;

qui fonctionne plutôt bien car elle me donne tous les codes postaux

ensuite je fais la même manip pour ModifVille que je colle ce code sql:
Select DISTINCT T_ville.Ville_nom From T_Code_postal Where T_Code_postal.ID_code_postal = Forms!AjoutNouveauClient!ModifCodepostal


Puis je reviens en mode création que je sélectionne ma liste Modifcodepostal mon ModifVille lui est vide!!
Pourquoi il me détecte t-il pas les villes pourtant toutes sont bien rempli ?

1 réponse

crn_c21 Messages postés 302 Date d'inscription samedi 24 janvier 2004 Statut Membre Dernière intervention 4 février 2011
20 févr. 2010 à 23:50
Peut etre faudrait-il modifier la synthaxe de la requète en :

"Select DISTINCT T_ville.Ville_nom From T_Code_postal Where T_Code_postal.ID_code_postal = '" & Forms!AjoutNouveauClient!ModifCodepostal & "'"
0