Nouvelle indication : version langage

Werteur Messages postés 2 Date d'inscription dimanche 2 septembre 2007 Statut Membre Dernière intervention 29 mai 2014 - 28 janv. 2010 à 06:12
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 - 13 avril 2010 à 08:02
Bonjour,

Je suis tout nouveau ici donc si ce que je m'apprête a dire n'est pas juste, ne me jetez pas la pierre ! Je m'en excuse d'avance. Je vais essayé d'être clair, je commence a peine apprendre le python et j'ai décider de venir consulter deux trois code source produit par la communauté, j'ai ensuite voulu les exécutés par curiosité et je me suis aperçu que cela m'était impossible.

En effet j'obtiens beaucoup d'erreur de syntaxe du au code print qui est passer en fonction et donc a changer de syntaxe a la version 3.0.1 de python, qui datent pourtant de 5 mois. Comme je suis nouveau j'ai télécharger la dernière version idle sans m'en préoccuper (des recherches périlleuse pour comprendre tout ça).

J'en viens donc au "Boîte à idées pour améliorer CodeS-SourceS" Pourquoi ne pas implémenter la possibilité d'afficher la compatibilité avec la bonne version de python, suivis d'un nouveau filtre approprié, les codes que j'ai essayé étaient pourtant très récent dans leurs dates d'ajout, mais n'étaient pas compatible. En tant que débutant naïf je pensais que les "développeurs" étaient très au faite de l'évolution du langage.

j'espère ne pas avoir dis trop de bêtise, en tout cas la volonté d'aider était là! Sur ce, bonne journée

1 réponse

cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
13 avril 2010 à 08:02
Il ne faut pas t'excuser.

Ce que tu dis est clair, et, sur ce site, il n'y a pas que des experts et c'est bien normal. L'important c'est de se faire comprendre.

Il est vrai que le langage Python évolue assez vite et cel apose certains problèmes parfois, il faudrait préciser avec quelle version d'idle un code a été développé, ca permettrait peut etre de le lire plus facilement.
0