[PB] projet tomcat, affichage d'une image sur la page d'accueil [Résolu]

vodka93 5 Messages postés lundi 16 juillet 2007Date d'inscription 21 janvier 2010 Dernière intervention - 21 janv. 2010 à 13:05 - Dernière réponse :  leoilyes
- 6 mars 2013 à 12:32
Bonjour,
Je sollicite votre aide car je n'arrive pas a afficher une image sur la page d'accueil d'un projet tomcat.

C'est un projet simple, dans lequel je dispose d'une page d'accueil avec l'extension .jsp et d'une servlet. La page d'accueil est composé que de code html, avec un formulaire qui redirige vers une servlet. ça fonctionne parfaitement.

Seulement, j'ai un problème pour afficher l'image sur la page d'acceuil. Avec un code du genre
,
aucun problème, l'image s'affiche correctement si je me connecte du poste local, seulement si je m'y connecte d'un autre poste, l'image ne s'affiche pas. Ce que je trouve normal.

J'ai donc tenter d'ajouter un dossier images dans le webcontent de mon projet, et modifier le code de cette façon :
.
Seulement l'image ne s'affiche pas même depuis le poste local.

Après de nombreuses recherche sur google, je n'ai pas trouver comment faire.
Est-ce que quelqu'un connait la démarche a suivre pour faire ça. Sachant qu'ensuite je souhaite créer un war puis le déployer sur un autre serveur tomcat. (production)

Merci d'avance.
cordialement
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
cs_DARKSIDIOUS 15838 Messages postés jeudi 8 août 2002Date d'inscriptionModérateurStatut 4 mars 2013 Dernière intervention - 21 janv. 2010 à 13:30
1
Merci
Salut,

Tout dépend où tu as stocké l'image par rapport à ta page jsp : si ton dossier "image" est dans le même dossier que ta jsp :


S'il est dans le dossier racine de ta jsp :


Note: il ne s'agit pas d'un problème concernant java, mais un problème concernant le langage HTML
______________________________________
DarK Sidious

Merci cs_DARKSIDIOUS 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 98 internautes ce mois-ci

Commenter la réponse de cs_DARKSIDIOUS
vodka93 5 Messages postés lundi 16 juillet 2007Date d'inscription 21 janvier 2010 Dernière intervention - 21 janv. 2010 à 14:31
0
Merci
Effectivement, ça fonctionne.
Merci d'avoir répondu aussi rapidement.
Commenter la réponse de vodka93
0
Merci
j'ai un problème je ajouter une image a mon travaille
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Insert title here</title>
</head>

<form>
<Center>

Bienvenue,

----

Admin,

----

Util

</Center>
</form>


mais quand je ouvrir le page dans le navigateur l'image n'affiche pas
aider moi s-v-p
Commenter la réponse de leoilyes

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.