Aider_ moi

Signaler
Messages postés
2
Date d'inscription
mercredi 20 janvier 2010
Statut
Membre
Dernière intervention
20 janvier 2010
-
Messages postés
2
Date d'inscription
mercredi 20 janvier 2010
Statut
Membre
Dernière intervention
20 janvier 2010
-
[color=]Bonjour
Je veux aider dans cet exercice
Je veux en faire dans programme c++/color
-------------------------------------------
[b]algorithme file_d'attente type pt=elem elem=structure num:entier next:pt finstructure

var tete,p,ptr,pred:pt; x:entier; rep:caractère

debut écrire('entrer votre numéro')l lire(x)l new(ptr)l ptr^.num<-x ptr^.next<-nil si tete=nil alors tete<-ptr sinon p<-tete tantque (p<>nil)et (x>p^.num) faire pred=p p<-p.next fintantque si p=tete alors (*insertion au debut*)l ptr^.next<-tete tete<-ptr sinon si p=nil alors (*insertion à la fin*)l pred^.next<-ptr sinon (*insertion au milieu*)l ptr^.next<-p pred^.next<-ptr finsi finsi finsi écrire('est ce qu'un malade est reçu par le dentiste' o/n)l lire(reponse)l si reponse='o' alors p<-tete tete<-tete.next dispos/be(p)l finsi fin

1 réponse

Messages postés
2
Date d'inscription
mercredi 20 janvier 2010
Statut
Membre
Dernière intervention
20 janvier 2010

algorithme
dans
---------------------------------
algorithme file_d'attente
type pt=elem
elem=structure
num:entier
next:pt
finstructure

var tete,p,ptr,pred:pt; x:entier; rep:caractère

debut
écrire('entrer votre numéro')l
lire(x)l
new(ptr)l
ptr^.num<-x
ptr^.next<-nil
si tete=nil alors
tete<-ptr
sinon
p<-tete
tantque (p<>nil)et (x>p^.num) faire
pred=p
p<-p.next
fintantque
si p=tete alors (*insertion au debut*)l
ptr^.next<-tete
tete<-ptr
sinon
si p=nil alors (*insertion à la fin*)l
pred^.next<-ptr
sinon (*insertion au milieu*)l
ptr^.next<-p
pred^.next<-ptr
finsi
finsi
finsi
écrire('est ce qu'un malade est reçu par le dentiste' o/n)l
lire(reponse)l
si reponse='o' alors
p<-tete
tete<-tete.next
dispose(p)l
finsi
fin