MySQL

begueradj Messages postés 273 Date d'inscription dimanche 4 octobre 2009 Statut Membre Dernière intervention 24 juin 2014 - 16 janv. 2010 à 19:30
zalza Messages postés 3 Date d'inscription lundi 18 janvier 2010 Statut Membre Dernière intervention 21 janvier 2010 - 21 janv. 2010 à 10:30
Bonjour à tous;

Je reçois toujours ce message lorsque j'utilise EasyPHP ou WAMP:

"La version due MySQe votre bibliothèqL (5.0.51a) diffère de la version de votre serveur MySQL (5.1.37). Ceci peut occasionner un comportement imprévisible."

Donc, la question est comment "rendre" ma version de bibliothèque MySQL compatible avec ma version de votre serveur MySQL ?

merci beaucoup pour une éventuelle réponse.

Begueradj

8 réponses

syndrael Messages postés 2378 Date d'inscription lundi 4 février 2002 Statut Membre Dernière intervention 29 décembre 2012 20
17 janv. 2010 à 07:20
T'inquiete ça n'a rien de bloquant. C'est fréquent sur PhPMyAdmin, connaissant très mal EasyPHP et Wamp je ne peux pas te donner la soluce.
S.
0
begueradj Messages postés 273 Date d'inscription dimanche 4 octobre 2009 Statut Membre Dernière intervention 24 juin 2014 9
17 janv. 2010 à 08:24
Merci Monsieur Syndrael;

Si je n'en ai pas la raison de m'inquiéter alors je ne vais pas m'inquiéter :)

Beguerajd.
0
begueradj Messages postés 273 Date d'inscription dimanche 4 octobre 2009 Statut Membre Dernière intervention 24 juin 2014 9
17 janv. 2010 à 08:27
mais si quelqu'un peut expliquer la raison de ce message affiché et comment y apporter une éventuelle solution, alors ça serait génial (à titre de curiosité)

Begueradj
0
kohntark Messages postés 3705 Date d'inscription lundi 5 juillet 2004 Statut Membre Dernière intervention 27 avril 2012 30
17 janv. 2010 à 11:00
Salut,

Quelle est ta version de PHP ?
As tu fait des upgrades indépendants de MySQL après l'install de easyPHP ?



Kohntark -
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
zalza Messages postés 3 Date d'inscription lundi 18 janvier 2010 Statut Membre Dernière intervention 21 janvier 2010
18 janv. 2010 à 14:32
Bonjour,

Il se trouve que j'ai exactement le même problème.
j'ai php 5.2.10 et le message "La version due MySQe votre bibliothèqL (5.0.51a) diffère de la version de votre serveur MySQL (5.1.37). Ceci peut occasionner un comportement imprévisible"


Ce n'est effectivement pas bloquant mais j'aimerai mieux ne pas avoir de message.

La seule piste que j'ai trouvé se trouve ici:
http://www.developpez.net/forums/d739298/php/outils/phpmyadmin/message-version-bibliotheque-mysql/

Testé mais ça n'a pas fonctionné (car vrai pour la version 5.2.9)
0
begueradj Messages postés 273 Date d'inscription dimanche 4 octobre 2009 Statut Membre Dernière intervention 24 juin 2014 9
19 janv. 2010 à 08:05
Bonjour;

merci pour vos 2 interventions.

Effectivement, j'ai lu et testé ce qui a été mentionné sur le lien (http://www.developpez.net/forums/d739298/php/outils/phpmyadmin/message-version-bibliotheque-mysql/ )
et ça a marché malgré que j'utilise la EasyPHP et non plus le WAMP.

Merci beaucoup pour vos réponses.
Begueradj
0
zalza Messages postés 3 Date d'inscription lundi 18 janvier 2010 Statut Membre Dernière intervention 21 janvier 2010
21 janv. 2010 à 08:59
Bonjour,

contente de savoir que ça marche.
Quelle version d'EasyPHP utilise-tu?
Tu as trouvé le fichier libmysql de mysql?
Dans le répertoire bin dont il parle sur le forum je n'ai que de exe....

Merci d'avance
0
zalza Messages postés 3 Date d'inscription lundi 18 janvier 2010 Statut Membre Dernière intervention 21 janvier 2010
21 janv. 2010 à 10:30
Juste pour Info, le message a disparu pour moi aussi.

Version EasyPHP 5.2.10
Serveur mySql 5.1.37
Extension PHP 5.0.51a

1. Arrêter EasyPhp

2. télécharger les bibliothèques php_mysql.dll et php_mysqli.dll à cette adresse
sauvegader les dll fournies par défaut et remplacer les par celles téléchargées dans le répertoire php/ext

3. télécharger le fichier libmysql.dll http://dl.free.fr/getfile.pl?file=/z3qnCZo8
(si il n'est pas présent dans le bin de mysql)
copier le libmysql.dll dans le bin du répertoire apache, dans C:/Windows/system32 ainsi que dans le bin de mysql

4. Redémarrer EasyPHP

Et le message "La version due MySQe votre bibliothèqL (5.0.51a) diffère de la version ...." a disparu!!!!!

J'espère que ça pourra aider!
0
Rejoignez-nous