ConfigurationManager non reconnu! [Résolu]

Messages postés
142
Date d'inscription
mardi 27 novembre 2007
Dernière intervention
10 mai 2010
- - Dernière réponse : JeremyLecouvert
Messages postés
142
Date d'inscription
mardi 27 novembre 2007
Dernière intervention
10 mai 2010
- 9 déc. 2009 à 14:22
Bonjour à tous,

Depuis un moment déjà, j'ai un petit souci dans VS2008 que je n'arrive pas à comprendre: L'espace de noms System.Configuration.ConfigurationManager n'est pas reconnu!

Du coup, j'utilise ConfigurationSettings (obsolète), ce qui en soit ne me plait pas vraiment, et forcément j'obtient toute une collection de messages 'ConfigurationSettings est obsolète, utilisez ConfigurationManager'... J'ai beau lui dire 'J'aimerais bien mais t'en veux pas, abruti!!!', il ne veut rien entendre.

J'ai essayé une réinstall du framework 3.5 et diverses autres manips mais sans succès.. si quelqu'un a déjà rencontré le problème ou a une idée, je suis tout ouïe... J'aime bien développer en c# mais les petits caprices de l'environnement NitroSoft commencent à me courir grave sur le haricot!!!

Merci d'avance.

Si l'envie te prend de travailler, assied-toi et attend qu'elle te passe! (vieux -et faux!- dicton corse)
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
1863
Date d'inscription
lundi 28 novembre 2005
Dernière intervention
14 février 2015
3
Merci
Salut

Il faut que tu référence la bonne dll (en l'occurrence System.Configuration je crois). Clic droit sur Références => Ajouter une référence

En effet, il ne faut pas confondre les using en haut de tes fichiers, qui sont juste des raccourcis d'écriture, et les référence, qui sont les fonctions apportées à ton programme.

Krimog : while (!(succeed = try())) ;
- Nous ne sommes pas des décodeurs ambulants. Le style SMS est prohibé ! -

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 98 internautes ce mois-ci

Commenter la réponse de krimog
Messages postés
142
Date d'inscription
mardi 27 novembre 2007
Dernière intervention
10 mai 2010
0
Merci
Effectivement, problème résolu!

La dll System était référencée, et je pensais que ConfigurationManager était dans cette dll, au même titre que l'ancien ConfigurationSettings... comme quoi, les classes partielles c'est bien pratique, mais c'est aussi bien le bordel pour s'y retrouver!! En tout cas un grand MERCI
... question réglée en - de temps qu'il ne faut pour l'écrire!!

@+.

Si l'envie te prend de travailler, assied-toi et attend qu'elle te passe! (vieux -et faux!- dicton corse)
Commenter la réponse de JeremyLecouvert
Messages postés
142
Date d'inscription
mardi 27 novembre 2007
Dernière intervention
10 mai 2010
0
Merci
PS: Wouah, quand je pense que j'ai réinstallé le framework...
j'me sens tout p'tit!


Si l'envie te prend de travailler, assied-toi et attend qu'elle te passe! (vieux -et faux!- dicton corse)
Commenter la réponse de JeremyLecouvert

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.