Update panel, Datalist & Postback. FF pas de probleme. IE sa marche une fois! [Résolu]

Signaler
Messages postés
6
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
29 décembre 2009
-
Messages postés
6
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
29 décembre 2009
-
Damn!!

Si quelqu'un peu me venir en aide avant que je m'arrache le peu de cheveux qu'il me reste sur le crane...

J'ai un update panel, une datalist. Dans la datalist, des photos, des boutons permettant de supprimer la photo, mettre en avatar, modifier le titre la description. Et un bouton en bas pour ajouter des photos.

Sous Firefox aucun probleme!

Sous ie, je ne peu faire qu'une action. En gros je supprime une photo sa fonctionne, si je veu en supprimer une autre pas possible!

A savoir j'ai un calendrier aussi a droite dans un autre update panel, c'est le meme probleme, sous ff nikel sour ie, on change de mois une fois ok mais pas deux!

Cycle de vie de ma page:

-PageLoad: je charge ma source de donnée et je bind
-Databinding: il genere l'affichage des photos et creer dynamiquement les boutons et champs sencer genrer mes postbacks asynchrone
-Handler de click: Eventuellement il est censer passer dans les gestionnaire devenements de mes boutons cliqué.
-PageLoadComplete: On recharge la source de donnée (Peut etre y a t'il eu des suppressions/modification) et je ReBind.

Pour tester:
http://www.supacats.com/connection
Pseudo: Lorah
Mot de passe : 555555

Puis la page en question -> http://www.supacats.com/gerer-mes-photos

3 réponses

Messages postés
6
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
29 décembre 2009

Bon bah j'ai regler mon probleme tout seul.

Plutot que de traffiquer mon rewriter, j'ai fait un petit javascript ki force le postback a amener vers la bonne url et non sur un dossier virtuel du rewriting :

var form = Sys.WebForms.PageRequestManager.getInstance()._form;
form._initialAction form.action window.location.href;
Messages postés
6
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
29 décembre 2009

Apparemment sa serait même pas un probleme entre firefox et ie.

C'est juste que de temps en temps sa fonctionne bien, et de temps en temps, sa fonctionne qu'une fois.

Je comprend vraiment pas!!
Messages postés
6
Date d'inscription
mardi 1 décembre 2009
Statut
Membre
Dernière intervention
29 décembre 2009

Je crois bien que sa vien de mon url rewriting....

Sur /gerer-mes-photos sa fonctionne qu'une fois
Sur /users/GestionPhotos.aspx sa marche bien

Doit y'avoir un truc avec mon rewrite path et le parametre rebase clientPath...