JSP TOMCAT pb simple .... mais pas pour moi!!!!

lebobby Messages postés 19 Date d'inscription vendredi 14 juin 2002 Statut Membre Dernière intervention 18 mars 2003 - 3 mars 2003 à 19:09
lebobby Messages postés 19 Date d'inscription vendredi 14 juin 2002 Statut Membre Dernière intervention 18 mars 2003 - 9 mars 2003 à 11:34
Bonjour,
je travailles sous XP avec TOMCAT 4.1.18.
Il est correctement installé (J'ai fait fonctionné les test JSP et SERVLET avec succès).
Mais voila, pour un tp, il faut que je crée une application MVC de gestion de cours, salles, profs,...
J'ai l'arborescence de fichier suivante :

REP_INSTALL_TOMCAT\webapps\cours\ ou j'ai placé mes fichiers jsp et html.
REP_INSTALL_TOMCAT\webapps\cours\WEB-INF\classes ou j'ai placé mes fichiers java et class des beans que j'ai crée.
REP_INSTALL_TOMCAT\webapps\cours\WEB-INF\lib ou j'ai placé un jar des fichiers class des beans que j'ai crée.

Mon problème est le suivant :
j'accède correctement à mes fichiers jsp qui font de l'affichage html en tapant http://localhost:8080/cours/fichier.jsp
mais ensuite j'essaie d'acceder a un de mes beans à l'aide de la commande :
<jsp:useBean id="connect" class="ConnectionBean"/
et la il me dit pb :

org.apache.jasper.JasperException: Unable to compile class for JSP

An error occurred at line: 1 in the jsp file: /consult.jsp

Generated servlet error:
[javac] Compiling 1 source file

C:\Program Files\Apache Group\Tomcat 4.1\work\Standalone\localhost\cours\consult_jsp.java:43: cannot resolve symbol
symbol : class ConnectionBean
location: class org.apache.jsp.consult_jsp
ConnectionBean connect = null;

Je n'ai touché a aucun fichier conf !!!!! et ConnectionBean est bien evidement une des classes contenues dans classes/ et est contenue dans le jar sous lib/
Que dois je faire ??????
Au secours!!!!!!!!

Merci d'avance et excusez moi pour ce message long mais je voulais que vous ayez toutes les informations nécessaires

=======================

Fred.

=======================
A voir également:

2 réponses

cs_vieuxLion Messages postés 455 Date d'inscription samedi 26 octobre 2002 Statut Membre Dernière intervention 6 avril 2004 8
9 mars 2003 à 00:23
salut
Tomcat est très capricieux... j'en suis témoin
Utilises tu des packages et si oui, as tu bien reproduit l'arborescence sous ton répertoire WEB_INF\classes ?
idem pour ton .JAR
0
lebobby Messages postés 19 Date d'inscription vendredi 14 juin 2002 Statut Membre Dernière intervention 18 mars 2003
9 mars 2003 à 11:34
Effectivement c'etait un problème de package que j'ai placé sous classes.
Merci de m'avoir aidé.

=======================

Fred.

=======================
0
Rejoignez-nous