Problème persistant : Accès refusé phpmyadmin [Résolu]

Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
- - Dernière réponse :  teirmer - 10 juil. 2010 à 13:12
Bonjour,

J'installe easyphp, dernière version à ce jour, pour débuter avec le php. Tout d'abord, je voulais tester ce qu'est joomla, alors je l'ai téléchargé et j'ai suivi l'aide disponible pour l'installation.
Mon problème est le suivant :

Il m'est impossible de créer une base de données mysql, pour la simple raison que, lorsque je veux aller sur phpmyadmin, à partir de l'administration easyphp, j'ai un message d'erreur me disant que l'accès est refusé et que les réglages sont incorects. Je n'ai fais aucune modification après l'installation. Pour être sûr, j'ai quand même vérifié les valeurs dans le fichier config.inc.php, et ça correspond bien à celles du serveur.

Après plusieurs réinstallations, de différentes versions, toujours rien. J'ai regardé plusieurs fils de discussion sur le sujet, mais rien ne correspondant vraiment à mon problème. Recherches Google, rien non plus.
J'ai fais exactement la même installation sur un pc fixe (même OS: vista), et là aucun problème, j'arrive à accèder à phpmyadmin. J'ai également tester WAMP sur mon pc, même problème.

Je ne sais vraiment plus quoi faire maintenant. Avez-vous une idée du problème ? Des problèmes de compatibilités avec d'autres logiciels peut-être?

Merci,
Cdlt
Afficher la suite 

20/79 réponses

Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Question con : as-tu un pare-feu qui empêcherait la connexion TCP sur le port 3306 ?

Est-ce que tu as Microsoft 2008 C++ Runtime installé ? Normalement, tu n'en as pas besoin, a priori EasyPHP utilise la bonne version de PHP5.3 (celle compilée avec Visual C++ 6 et pas Visual C++ 9). Pour s'en assurer => Est-ce que tu peux essayer de remplacer ta version de PHP par celle fournie sur le site de php.net ? => celle-là
Pour ce faire, il suffit de copier le contenu du répertoire PHP ailleurs en attendant, et d'extraire l'archive à la place, puis relancer Apache (éventuellement, faire attention aux extensions chargées, qui doivent bien être présentes, mais bon, c'est du détail à voir par toi-même sur ta machine)

J'avais menti, j'ai eu d'autres idées... Maintenant, je suis vraiment à court...

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Le pare-feu Vista... rien d'autre.
Il me semble pas avoir Microsoft 2008 C++ Runtime non. J'ai visual basic 2008 express edition.

J'ai remplacé le dossier php par ce que tu as proposé, rien de neuf.... la même erreur au lancement de phpmyadmin.

Bonne nuit
Commenter la réponse de xscreamm
Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Est-ce que tu as essayé de désactiver le pare-feu Vista, juste pour voir ?
C'est peut-être une question à la con, mais bon, au point où on en est, faut s'assurer que c'est pas ça... :/

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
J'ai essayé. Et toujours rien, la même erreur s'affiche.
Commenter la réponse de xscreamm
Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Bon...

J'ai plus que deux questions cons :
- as-tu une corde ?
- sais-tu faire un noeud coulant ?

J'ai épuisé le stock. :/

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Bon... ok
Enième essai: j'ai obtenu un message différent en tentant de me connecter au serveur en ligne de commande. Peut-être qu'il y a d'autres infos intéressantes là-dedans... :

C:\Program Files\EasyPHP5.3.0\mysql\bin>mysql _u root -p
mysql Ver 14.14 Distrib 5.1.37, for Win32 (ia32)
Copyright 2000-2008 MySQL AB, 2008 Sun Microsystems, Inc.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license
Usage: mysql [OPTIONS] [database]
-?, --help Display this help and exit.
-I, --help Synonym for -?
--auto-rehash Enable automatic rehashing. One doesn't need to use
'rehash' to get table and field completion, but startup
and reconnecting may take a longer time. Disable with
--disable-auto-rehash.
-A, --no-auto-rehash
No automatic rehashing. One has to use 'rehash' to get
table and field completion. This gives a quicker start of
mysql and disables rehashing on reconnect. WARNING:
options deprecated; use --disable-auto-rehash instead.
-B, --batch Don't use history file. Disable interactive behavior.
(Enables --silent)
--character-sets-dir=name
Directory where character sets are.
--column-type-info Display column type information.
-c, --comments Preserve comments. Send comments to the server. The
default is --skip-comments (discard comments), enable
with --comments
-C, --compress Use compression in server/client protocol.
-#, --debug[=#] This is a non-debug version. Catch this and exit
--debug-check Check memory and open file usage at exit.
-T, --debug-info Print some debug info at exit.
-D, --database=name Database to use.
--default-character-set=name
Set the default character set.
--delimiter=name Delimiter to be used.
-e, --execute=name Execute command and quit. (Disables --force and history
file)
-E, --vertical Print the output of a query (rows) vertically.
-f, --force Continue even if we get an sql error.
-G, --named-commands
Enable named commands. Named commands mean this program's
internal commands; see mysql> help . When enabled, the
named commands can be used from any line of the query,
otherwise only from the first line, before an enter.
Disable with --disable-named-commands. This option is
disabled by default.
-g, --no-named-commands
Named commands are disabled. Use \* form only, or use
named commands only in the beginning of a line ending
with a semicolon (;) Since version 10.9 the client now
starts with this option ENABLED by default! Disable with
'-G'. Long format commands still work from the first
line. WARNING: option deprecated; use
--disable-named-commands instead.
-i, --ignore-spaces Ignore space after function names.
--local-infile Enable/disable LOAD DATA LOCAL INFILE.
-b, --no-beep Turn off beep on error.
-h, --host=name Connect to host.
-H, --html Produce HTML output.
-X, --xml Produce XML output
--line-numbers Write line numbers for errors.
-L, --skip-line-numbers
Don't write line number for errors. WARNING: -L is
deprecated, use long version of this option instead.
-n, --unbuffered Flush buffer after each query.
--column-names Write column names in results.
-N, --skip-column-names
Don't write column names in results. WARNING: -N is
deprecated, use long version of this options instead.
-O, --set-variable=name
Change the value of a variable. Please note that this
option is deprecated; you can set variables directly with
--variable-name=value.
--sigint-ignore Ignore SIGINT (CTRL-C)
-o, --one-database Only update the default database. This is useful for
skipping updates to other database in the update log.
-p, --password[=name]
Password to use when connecting to server. If password is
not given it's asked from the tty.
-W, --pipe Use named pipes to connect to server.
-P, --port=# Port number to use for connection or 0 for default to, in
order of preference, my.cnf, $MYSQL_TCP_PORT,
/etc/services, built-in default (3306).
--prompt=name Set the mysql prompt to this value.
--protocol=name The protocol of connection (tcp,socket,pipe,memory).
-q, --quick Don't cache result, print it row by row. This may slow
down the server if the output is suspended. Doesn't use
history file.
-r, --raw Write fields without conversion. Used with --batch.
--reconnect Reconnect if the connection is lost. Disable with
--disable-reconnect. This option is enabled by default.
-s, --silent Be more silent. Print results with a tab as separator,
each row on new line.
--shared-memory-base-name=name
Base name of shared memory.
-S, --socket=name Socket file to use for connection.
--ssl Enable SSL for connection (automatically enabled with
other flags). Disable with --skip-ssl.
--ssl-ca=name CA file in PEM format (check OpenSSL docs, implies
--ssl).
--ssl-capath=name CA directory (check OpenSSL docs, implies --ssl).
--ssl-cert=name X509 cert in PEM format (implies --ssl).
--ssl-cipher=name SSL cipher to use (implies --ssl).
--ssl-key=name X509 key in PEM format (implies --ssl).
--ssl-verify-server-cert
Verify server's "Common Name" in its cert against
hostname used when connecting. This option is disabled by
default.
-t, --table Output in table format.
--tee=name Append everything into outfile. See interactive help (\h)
also. Does not work in batch mode. Disable with
--disable-tee. This option is disabled by default.
--no-tee Disable outfile. See interactive help (\h) also. WARNING:
option deprecated; use --disable-tee instead
-u, --user=name User for login if not current user.
-U, --safe-updates Only allow UPDATE and DELETE that uses keys.
-U, --i-am-a-dummy Synonym for option --safe-updates, -U.
-v, --verbose Write more. (-v -v -v gives the table output format).
-V, --version Output version information and exit.
-w, --wait Wait and retry if connection is down.
--connect_timeout=# Number of seconds before connection timeout.
--max_allowed_packet=#
Max packet length to send to, or receive from server
--net_buffer_length=#
Buffer for TCP/IP and socket communication
--select_limit=# Automatic limit for SELECT when using --safe-updates
--max_join_size=# Automatic limit for rows in a join when using
--safe-updates
--secure-auth Refuse client connecting to server if it uses old
(pre-4.1.1) protocol
--server-arg=name Send embedded server this as a parameter.
--show-warnings Show warnings after every statement.

Default options are read from the following files in the given order:
C:\Windows\my.ini C:\Windows\my.cnf C:\my.ini C:\my.cnf C:\Program Files\EasyPHP
5.3.0\mysql\my.ini C:\Program Files\EasyPHP5.3.0\mysql\my.cnf
The following groups are read: mysql client
The following options may be given as the first argument:
--print-defaults Print the program argument list and exit
--no-defaults Don't read default options from any options file
--defaults-file=# Only read default options from the given file #
--defaults-extra-file=# Read this file after the global files are read

Variables (--variable-name=value)
and boolean options {FALSE|TRUE} Value (after reading options)
--------------------------------- -----------------------------
auto-rehash FALSE
character-sets-dir (No default value)
column-type-info FALSE
comments FALSE
compress FALSE
debug-check FALSE
debug-info FALSE
database (No default value)
default-character-set utf8
delimiter ;
vertical FALSE
force FALSE
named-commands FALSE
ignore-spaces FALSE
local-infile FALSE
no-beep FALSE
host (No default value)
html FALSE
xml FALSE
line-numbers TRUE
unbuffered FALSE
column-names TRUE
sigint-ignore FALSE
port 3306
prompt mysql>
quick FALSE
raw FALSE
reconnect TRUE
shared-memory-base-name (No default value)
socket /tmp/mysql.sock
ssl FALSE
ssl-ca (No default value)
ssl-capath (No default value)
ssl-cert (No default value)
ssl-cipher (No default value)
ssl-key (No default value)
ssl-verify-server-cert FALSE
table FALSE
user (No default value)
safe-updates FALSE
i-am-a-dummy FALSE
connect_timeout 0
max_allowed_packet 16777216
net_buffer_length 16384
select_limit 1000
max_join_size 1000000
secure-auth FALSE
show-warnings FALSE
Commenter la réponse de xscreamm
Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Arf... c'est pas
mysql _u root -p

mais
mysql -u root -p


Du coup le message, c'est pour t'expliquer ce que tu as le droit d'utiliser comme argument :'/

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
Amis du soir bonsoir,

Xscreamm, il va peut être falloir penser à payer nos honoraires (gaffe Neige est très cher )
Je rentre de formation est à vrai dire j'en ai plein les bask ...
J'ai tout de même pris le temps de lire ce que je t'avais demandé, et il y a des erreurs !!

Dans un premier temps :
- en ligne de commande entre :
net stop mysql
- renomme le fichier my.ini (en my.old par exemple) afin de le sauvegarder.
- crées un nouveau fichier my.ini dans lequel tu copies ces lignes :

[client]
port=3306

[mysql]
default-character-set=utf8


[mysqld]
port=3306
basedir="C:/Program Files/EasyPHP5.3.0/mysql/"
datadir="C:/Program Files/EasyPHP5.3.0/mysql/data/"
key_buffer_size = 16M
max_allowed_packet = 1M
table_open_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M


- en ligne de commande :
net start mysql

Vérifie que le message est bien un truc du genre "mysql a démarré")

- en ligne de commande :
mysqladmin -u [ton nom d'utilisateur] -p[ton mot de passe] -h localhost variables > c:/bug_ki_prend_la_tete.txt
Poste le fichier "c:/bug_ki_prend_la_tete.txt"

- ré exécute truc.php

Qu'en est il ?

Cordialement,

Kohntark -
Commenter la réponse de kohntark
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Alors, déjà merci de chercher, encore et encore...

Dans un premier temps, en ligne de commande, quand je fais "net stop mysql" (dans easyphp5.3.0/mysql/bin c'est bien ça ?) ça me fais une erreur :
-------------------------------------------------------------------------
L'erreur système 1060 s'est produite.

Le service spécifié n'existe pas en tant que service installé.
-------------------------------------------------------------------------
Bref, ça n'arrête pas le serveur, donc je le stoppe depuis easyphp.
J'ai remplacé le fichier my.ini

Quand je fais net start mysql, ça me fais:
--------------------------------------------------------------------------
Le nom de service n'est pas valide.

Vous obtiendrez une aide supplémentaire en entrant NET HELPMSG 2185.
-----------------------------------------------------------------------------
Donc je démarre le serveur en lancant easyphp.

Voici le fichier bug_ki_prend_la_tete.txt :
-----------------------------------------------------------------------------
+-----------------------------------------+-------------------------------------------------------------------------------------------+
| Variable_name | Value |
+-----------------------------------------+-------------------------------------------------------------------------------------------+
| auto_increment_increment | 1 |
| auto_increment_offset | 1 |
| autocommit | ON |
| automatic_sp_privileges | ON |
| back_log | 50 |
| basedir | C:\Program Files\EasyPHP5.3.0\mysql\ |
| big_tables | OFF |
| binlog_cache_size | 32768 |
| binlog_format | STATEMENT |
| bulk_insert_buffer_size | 8388608 |
| character_set_client | latin1 |
| character_set_connection | latin1 |
| character_set_database | latin1 |
| character_set_filesystem | binary |
| character_set_results | latin1 |
| character_set_server | latin1 |
| character_set_system | utf8 |
| character_sets_dir | C:\Program Files\EasyPHP5.3.0\mysql\share\charsets\ |
| collation_connection | latin1_swedish_ci |
| collation_database | latin1_swedish_ci |
| collation_server | latin1_swedish_ci |
| completion_type | 0 |
| concurrent_insert | 1 |
| connect_timeout | 10 |
| datadir | C:\Program Files\EasyPHP5.3.0\mysql\data\ |
| date_format | %Y-%m-%d |
| datetime_format | %Y-%m-%d %H:%i:%s |
| default_week_format | 0 |
| delay_key_write | ON |
| delayed_insert_limit | 100 |
| delayed_insert_timeout | 300 |
| delayed_queue_size | 1000 |
| div_precision_increment | 4 |
| engine_condition_pushdown | ON |
| error_count | 0 |
| event_scheduler | OFF |
| expire_logs_days | 0 |
| flush | OFF |
| flush_time | 1800 |
| foreign_key_checks | ON |
| ft_boolean_syntax | + -><()~*:""&| |
| ft_max_word_len | 84 |
| ft_min_word_len | 4 |
| ft_query_expansion_limit | 20 |
| ft_stopword_file | (built-in) |
| general_log | OFF |
| general_log_file | C:\Program Files\EasyPHP5.3.0\mysql\data\PC-de-Aur |
| group_concat_max_len | 1024 |
| have_community_features | YES |
| have_compress | YES |
| have_crypt | NO |
| have_csv | YES |
| have_dynamic_loading | YES |
| have_geometry | YES |
| have_innodb | YES |
| have_ndbcluster | NO |
| have_openssl | DISABLED |
| have_partitioning | YES |
| have_query_cache | YES |
| have_rtree_keys | YES |
| have_ssl | DISABLED |
| have_symlink | YES |
| hostname | PC-de-Aur |
| identity | 0 |
| ignore_builtin_innodb | OFF |
| init_connect | |
| init_file | |
| init_slave | |
| innodb_adaptive_hash_index | ON |
| innodb_additional_mem_pool_size | 1048576 |
| innodb_autoextend_increment | 8 |
| innodb_autoinc_lock_mode | 1 |
| innodb_buffer_pool_size | 8388608 |
| innodb_checksums | ON |
| innodb_commit_concurrency | 0 |
| innodb_concurrency_tickets | 500 |
| innodb_data_file_path | ibdata1:10M:autoextend |
| innodb_data_home_dir | |
| innodb_doublewrite | ON |
| innodb_fast_shutdown | 1 |
| innodb_file_io_threads | 4 |
| innodb_file_per_table | OFF |
| innodb_flush_log_at_trx_commit | 1 |
| innodb_flush_method | |
| innodb_force_recovery | 0 |
| innodb_lock_wait_timeout | 50 |
| innodb_locks_unsafe_for_binlog | OFF |
| innodb_log_buffer_size | 1048576 |
| innodb_log_file_size | 5242880 |
| innodb_log_files_in_group | 2 |
| innodb_log_group_home_dir | .\ |
| innodb_max_dirty_pages_pct | 90 |
| innodb_max_purge_lag | 0 |
| innodb_mirrored_log_groups | 1 |
| innodb_open_files | 300 |
| innodb_rollback_on_timeout | OFF |
| innodb_stats_on_metadata | ON |
| innodb_support_xa | ON |
| innodb_sync_spin_loops | 20 |
| innodb_table_locks | ON |
| innodb_thread_concurrency | 8 |
| innodb_thread_sleep_delay | 10000 |
| innodb_use_legacy_cardinality_algorithm | ON |
| insert_id | 0 |
| interactive_timeout | 28800 |
| join_buffer_size | 131072 |
| keep_files_on_create | OFF |
| key_buffer_size | 16777216 |
| key_cache_age_threshold | 300 |
| key_cache_block_size | 1024 |
| key_cache_division_limit | 100 |
| language | C:\Program Files\EasyPHP5.3.0\mysql\share\french\ |
| large_files_support | ON |
| large_page_size | 0 |
| large_pages | OFF |
| last_insert_id | 0 |
| lc_time_names | en_US |
| license | GPL |
| local_infile | ON |
| log | OFF |
| log_bin | OFF |
| log_bin_trust_function_creators | OFF |
| log_bin_trust_routine_creators | OFF |
| log_error | C:\Program Files\EasyPHP5.3.0\mysql\data\PC-de-Aur |
| log_output | FILE |
| log_queries_not_using_indexes | OFF |
| log_slave_updates | OFF |
| log_slow_queries | OFF |
| log_warnings | 1 |
| long_query_time | 10.000000 |
| low_priority_updates | OFF |
| lower_case_file_system | ON |
| lower_case_table_names | 1 |
| max_allowed_packet | 1048576 |
| max_binlog_cache_size | 4294963200 |
| max_binlog_size | 1073741824 |
| max_connect_errors | 10 |
| max_connections | 151 |
| max_delayed_threads | 20 |
| max_error_count | 64 |
| max_heap_table_size | 16777216 |
| max_insert_delayed_threads | 20 |
| max_join_size | 18446744073709551615 |
| max_length_for_sort_data | 1024 |
| max_prepared_stmt_count | 16382 |
| max_relay_log_size | 0 |
| max_seeks_for_key | 4294967295 |
| max_sort_length | 1024 |
| max_sp_recursion_depth | 0 |
| max_tmp_tables | 32 |
| max_user_connections | 0 |
| max_write_lock_count | 4294967295 |
| min_examined_row_limit | 0 |
| multi_range_count | 256 |
| myisam_data_pointer_size | 6 |
| myisam_max_sort_file_size | 2146435072 |
| myisam_recover_options | OFF |
| myisam_repair_threads | 1 |
| myisam_sort_buffer_size | 8388608 |
| myisam_stats_method | nulls_unequal |
| myisam_use_mmap | OFF |
| named_pipe | OFF |
| net_buffer_length | 8192 |
| net_read_timeout | 30 |
| net_retry_count | 10 |
| net_write_timeout | 60 |
| new | OFF |
| old | OFF |
| old_alter_table | OFF |
| old_passwords | OFF |
| open_files_limit | 755 |
| optimizer_prune_level | 1 |
| optimizer_search_depth | 62 |
| optimizer_switch | index_merge=on,index_merge_union=on,index_merge_sort_union=on,index_merge_intersection=on |
| pid_file | C:\Program Files\EasyPHP5.3.0\mysql\data\PC-de-Aur |
| plugin_dir | C:\Program Files\EasyPHP5.3.0\mysql\lib/plugin |
| port | 3306 |
| preload_buffer_size | 32768 |
| profiling | OFF |
| profiling_history_size | 15 |
| protocol_version | 10 |
| pseudo_thread_id | 0 |
| query_alloc_block_size | 8192 |
| query_cache_limit | 1048576 |
| query_cache_min_res_unit | 4096 |
| query_cache_size | 0 |
| query_cache_type | ON |
| query_cache_wlock_invalidate | OFF |
| query_prealloc_size | 8192 |
| rand_seed1 | |
| rand_seed2 | |
| range_alloc_block_size | 4096 |
| read_buffer_size | 262144 |
| read_only | OFF |
| read_rnd_buffer_size | 524288 |
| relay_log | |
| relay_log_index | |
| relay_log_info_file | relay-log.info |
| relay_log_purge | ON |
| relay_log_space_limit | 0 |
| report_host | |
| report_password | |
| report_port | 3306 |
| report_user | |
| rpl_recovery_rank | 0 |
| secure_auth | OFF |
| secure_file_priv | |
| server_id | 0 |
| shared_memory | OFF |
| shared_memory_base_name | MYSQL |
| skip_external_locking | ON |
| skip_networking | OFF |
| skip_show_database | OFF |
| slave_compressed_protocol | OFF |
| slave_exec_mode | STRICT |
| slave_load_tmpdir | C:\Users\AURLIE~1\AppData\Local\Temp |
| slave_net_timeout | 3600 |
| slave_skip_errors | OFF |
| slave_transaction_retries | 10 |
| slow_launch_time | 2 |
| slow_query_log | OFF |
| slow_query_log_file | C:\Program Files\EasyPHP5.3.0\mysql\data\PC-de-Aur |
| sort_buffer_size | 524288 |
| sql_auto_is_null | ON |
| sql_big_selects | ON |
| sql_big_tables | OFF |
| sql_buffer_result | OFF |
| sql_log_bin | ON |
| sql_log_off | OFF |
| sql_log_update | ON |
| sql_low_priority_updates | OFF |
| sql_max_join_size | 18446744073709551615 |
| sql_mode | |
| sql_notes | ON |
| sql_quote_show_create | ON |
| sql_safe_updates | OFF |
| sql_select_limit | 18446744073709551615 |
| sql_slave_skip_counter | |
| sql_warnings | OFF |
| ssl_ca | |
| ssl_capath | |
| ssl_cert | |
| ssl_cipher | |
| ssl_key | |
| storage_engine | MyISAM |
| sync_binlog | 0 |
| sync_frm | ON |
| system_time_zone | Paris, Madrid |
| table_definition_cache | 256 |
| table_lock_wait_timeout | 50 |
| table_open_cache | 64 |
| table_type | MyISAM |
| thread_cache_size | 0 |
| thread_handling | one-thread-per-connection |
| thread_stack | 196608 |
| time_format | %H:%i:%s |
| time_zone | SYSTEM |
| timed_mutexes | OFF |
| timestamp | 1259090760 |
| tmp_table_size | 16777216 |
| tmpdir | C:\Users\AURLIE~1\AppData\Local\Temp |
| transaction_alloc_block_size | 8192 |
| transaction_prealloc_size | 4096 |
| tx_isolation | REPEATABLE-READ |
| unique_checks | ON |
| updatable_views_with_limit | YES |
| version | 5.1.37-community |
| version_comment | MySQL Community Server (GPL) |
| version_compile_machine | ia32 |
| version_compile_os | Win32 |
| wait_timeout | 28800 |
| warning_count | 5 |
+-----------------------------------------+-------------------------------------------------------------------------------------------+

Quand je lance truc.php, ça me fais ça:
Parse error: parse error in C:\Program Files\EasyPHP5.3.0\www\truc.php on line 2
Commenter la réponse de xscreamm
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
tu n'avais pas cette erreur avant, tu n'as rien ajouté ?
Poste le code de ce fichier stp (remplace juste le mot de passe par des *, laisse le reste intact)


Kohntark -
Commenter la réponse de kohntark
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Pardon mais quel fichier ?
my.ini ?

Sache qu'il n'y a pas de mot de passe.... je ne vais pas compliquer les choses en plus....
Commenter la réponse de xscreamm
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
J'aurai dû le préciser, mais je parlais de ça :
Quand je lance truc.php, ça me fais ça:
Parse error: parse error in C:\Program Files\EasyPHP5.3.0\www\truc.php on line 2


... le fichier truc.php donc.


Kohntark -
Commenter la réponse de kohntark
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Oups, je suis fatigué, j'avais oublié de remplacer mon nom d'utilisateur. Donc j'obtiens la même erreur que la dernière fois:

Warning: mysql_connect() [function.mysql-connect]: in C:\Program Files\EasyPHP5.3.0\www\truc.php on line 2

Le code que tu m'as donné dans un précédent message, c'est donc celui là:

<?php
if (false === mysql_connect('localhost', 'root, '')) die (mysql_error()); else echo 'connexion OK';
?>
Commenter la réponse de xscreamm
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
Non, je t'ai donné :
<?php
if (false === mysql_connect('localhost', 'root', '')) die (mysql_error()); else echo 'connexion OK';
?>

(le ' après root)
Il faut faire attention à ce que tu recopies sinon nous ne sommes pas prêt d'en sortir.


Dans un premier temps, en ligne de commande, quand je fais "net stop mysql" (dans easyphp5.3.0/mysql/bin c'est bien ça ?) ça me fais une erreur :
-------------------------------------------------------------------------
L'erreur système 1060 s'est produite.

Le service spécifié n'existe pas en tant que service installé.


Pas normal non plus ça d'après ce que tu avais dit dans un précédent post, à moins que ça ne soit dû à easyPHP, mais je doute.

Si tu fais (en gardant le même my.ini que celui que je t'ai donné) :
- en ligne de commande :
path
=> recopie la réponse


(1)- CTRL + ALT + SUPP, puis "ouvrir le gestionnaire des tâches", puis onglet "processus"
mysqld apparait il ?

Démarrer > Executer
- Tu entres :
services.msc

- Dans la fenêtre qui s'ouvre cherche "mysql".
(2)- Dans état : est il noté "démarrer" ? Si non, click droit > démarrer
- Double click sur la ligne, une fenêtre "propriété de mysql" s'ouvre.
- Recopie ce qu'il y a noté dans "Chemin d'accès des fichiers exécutables" (un truc du style : "C:\[chemin]\mysqld" --defaults-file=[...]")
- Ferme la fenêtre en cliquant sur OK

- en ligne de commande :
net stop mysql
=> quel est le message ?

- redémarre ton pc, relance easyPHP
- re répond au point (1) ci dessus. Si mysqld n'apparait pas passe au point (2)
- appelle truc.php
=> même message d'erreur ?
=> remplace le contenu de truc.php par :
<?php
if (false === mysql_connect('127.0.0.1', 'root, '')) die (mysql_error()); else echo 'connexion OK';
?>

toujours pas ? Tente en remplacant "127.0.0.1" par l'IP de ton pc (ça devient un peu du n'importe quoi là, c'est juste pour lever des doutes)


Cordialement,


Kohntark -
Commenter la réponse de kohntark
Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Par défaut, MySQL n'est pas installé en tant que Service Windows : on peut le choisir lors de l'installation du binaire Windows, mais pas quand on utilise EasyPHP. Il y a une manip pour installer le service, mais j'ai pas le temps de chercher là maintenant tout de suite, j'ai mes pâtes sur le feu.

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
2483
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
13
0
Merci
Bon j'ai plus faim...

Suite de mon message précédent :
http://dev.mysql.com/doc/refman/5.0/fr/windows-start-service.html

--
Neige

Souvent la réponse à votre question se trouve dans la doc. Commencez par là ;)
Commenter la réponse de neigedhiver
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
Mauvaise recopie mais c'était bien le bon code dans le fichier truc.php, désolé

Si tu fais (en gardant le même my.ini que celui que je t'ai donné) :
- en ligne de commande :
path
=> recopie la réponse


C:\Program Files\EasyPHP5.3.0\mysql\bin>path
PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Windows\syst
em32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Common Files\Roxio Sha
red\DLLShared\;C:\Program Files\Common Files\Roxio Shared\DLLShared\;C:\Program
Files\Common Files\Roxio Shared\9.0\DLLShared\;C:\Program Files\Samsung\Samsung
PC Studio 3\;C:\Program Files\Common Files\DivX Shared\;C:\Program Files\QuickTi
me\QTSystem\;C:\Program Files\Common Files\Microsoft Shared\Windows Live

Oui donc "mysqld" apparaît bien dans les processus. Pas dans les services par contre, normal d'après Neige apparement?

- en ligne de commande :
net stop mysql
=> quel est le message ?

L'erreur système 1060 s'est produite.

Le service spécifié n'existe pas en tant que service installé.

- appelle truc.php
=> même message d'erreur ?
=> remplace le contenu de truc.php par :

Code PHP :<?php
if (false === mysql_connect('127.0.0.1', 'root, '')) die (mysql_error()); else echo 'connexion OK';
?>

Là, ça me fais "connexion OK"
Commenter la réponse de xscreamm
Messages postés
38
Date d'inscription
dimanche 15 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2009
0
Merci
J'ai installé mysql en tant que service.
Commenter la réponse de xscreamm
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
Là, ça me fais "connexion OK"

Ben voilà, ça devrait le faire en te connectant à phpMyAdmin !!!

Il faudra peut être re modifier un peu le my.ini, mais pour l'heure utilises le comme ça et fait nous part des erreurs que tu pourrais rencontrer.

@Neige : j'ai un doute sur le fait qu'il ne soit pas installé en tant que service par défaut (c'est ce qui est recommandé dixit ton lien, ce qui ne veut pas dire qu'il ne le soit pas)
Dans le cadre d'easyPhp :
"à moins que ça ne soit dû à easyPHP, mais je doute."
le doute est levé.

Bon, je pense que le problème est réglé. Il se trouvait en fait dans le my.ini, mais je doute fort que le serveur ait été relancé après la modif, ceci expliquant cela.

Tiens nous au courant xscreamm.

Cordialement,


Kohntark -
Commenter la réponse de kohntark
Messages postés
3708
Date d'inscription
lundi 5 juillet 2004
Statut
Membre
Dernière intervention
27 avril 2012
21
0
Merci
Là, ça me fais "connexion OK"

Laisse donc tel quel !!! Si tu touches à la config, easyPHP risque de ne pas aimer.


Kohntark -
Commenter la réponse de kohntark