Soucis incomprehensible de get URL [Résolu]

Signaler
Messages postés
20
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
9 novembre 2009
-
Messages postés
20
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
9 novembre 2009
-
Salut à tous.

Encore une des magies de Flash, les bugs qu'on ne vois pas.

J'ai fait un petit menu ultra simple pour ce site:
http://24-design.fr/cazamajour/

C'est le petit menu à droite avec les catégories.
Chaque bouton a donc un getURL, mais alors que ça marche bien quand je compile depuis Flash, une fois dans le navigateur, si ce n'est pas avec un _blank, ça ne marche pas, que ce soit sans indicateur , avec un _self, _top ou _parent.
Donc c'est un peu gênant un site qui ouvre tout dans de nouvelles pages

J'ai tout tester, les on press, on release,... ça change rien.
J'ai testé aussi qu'au clic ça appelle une fonction au _root.... quedal...

Je vous met le code d'un de mes boutons, mais vous allez voir y'a pas plus simple:
on (release) {
getURL("http://24-design.fr/cazamajour/?cat=16", "_blank");

}


J'ai aussi essayer avec http:// et http://www.
Mais rien n'y change.

Est-ce que vous auriez la solution?

Merci beaucoup

Pierre

1 réponse

Messages postés
20
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
9 novembre 2009

Pour ceux qui ont le même soucis, j'ai trouvé.

chez moi ça a été résolut en appelant le swf comme ceci:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="  http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0  " width="550" height="400" id="Sans nom-1" align="middle" allowScriptAccess="always">


</object>


c'était le allowScriptAccess="always" qui était necéssaire