VBA ou formule Excel [Résolu]

Signaler
Messages postés
20
Date d'inscription
vendredi 13 mars 2009
Statut
Membre
Dernière intervention
1 février 2012
-
Messages postés
20
Date d'inscription
vendredi 13 mars 2009
Statut
Membre
Dernière intervention
1 février 2012
-
Bonjour,

j'expose le problème :

j'ai 2 fichiers dans lesquels se trouve des données dont une colonne de noms et une autre de dates de naissance.
Dans l'un de ces 2 fichiers se trouve une colonne avec les numéros de sécu.

Je souhaiterai à l'aide d'une macro, voir d'une formule, recopier le numéro de sécu dans le fichier où il n'y a pas cette information, en fonction des données de naissance et du nom.

J'ai tenté des formule avec =si(et( avec =si(recherchev(... mais ca ne donne pas grand chose...

Merci de votre aide.

2 réponses

Messages postés
181
Date d'inscription
mardi 18 novembre 2008
Statut
Membre
Dernière intervention
4 février 2011

Hello,
Moi ce que je ferais à ta place :
Vérifiez que pour tes 2 fichiers les colonnes nom et date de naissance soient au même format (majuscule ou pas, accent ou pas...)
Rassembler ces 2 colonnes dans une nouvelle colonne à l'aide de "&" ou de concatener() à placer en 1ère position (tout à gauche)
Une fois cette opération réalisée dans les 2 fichiers, tu pourras utiliser la fonction recherchev
exemple :
=RECHERCHEV(A1;fichier2$A:$K;5;FAUX)

BR
USERRRQI115
Simple user
Great brain
Messages postés
20
Date d'inscription
vendredi 13 mars 2009
Statut
Membre
Dernière intervention
1 février 2012

Bonjour,

ca marche parfaitement!

Merci!