Besoin d'information sur vBulletin/Templates

Signaler
Messages postés
65
Date d'inscription
jeudi 20 janvier 2005
Statut
Membre
Dernière intervention
25 juin 2010
-
Messages postés
65
Date d'inscription
jeudi 20 janvier 2005
Statut
Membre
Dernière intervention
25 juin 2010
-
Bonjour,

J'aurais besoin de quelques info (si certaines persnnes connaissent :p) sur l'utilisation des templates dans vBulletin.
Mon but est d'utiliser le forum comme base, et de creer une extension site web.
Pour cela j'ai besoin de savoir comment recup. & parse les templates sous vBulletin,

Merci d'avance,

dakm

1 réponse

Messages postés
65
Date d'inscription
jeudi 20 janvier 2005
Statut
Membre
Dernière intervention
25 juin 2010

Ajout d'info,

J'ai reussi a utiliser un peu les templates

<?php
// ####################### SET PHP ENVIRONMENT ###########################
error_reporting(E_ALL & ~E_NOTICE & ~8192);

// #################### DEFINE IMPORTANT CONSTANTS #######################
define('THIS_SCRIPT', 'ow_home');


// ################### PRE-CACHE TEMPLATES AND DATA ######################
// get special phrase groups
$phrasegroups = array();

// get special data templates from the datastore
$specialtemplates = array(

);

// pre-cache templates used by all actions
$globaltemplates = array(
'ow_header',
'ow_navbar',
'OW_HOME',

);

// pre-cache templates used by specific actions
$actiontemplates = array();

// ######################### REQUIRE BACK-END ############################
require_once('./global.php');
require_once('./ow_definition.php');
/*
if (is_online())

{
print_no_permission();
}
*/
eval('$header = "' . fetch_template('ow_header') . '"');
eval('$navbar = "' . fetch_template('ow_navbar') . '";');
eval('print_output("' . fetch_template('OW_HOME') . '");');

?>


Si j'enleve la ligne:
eval('$header = "' . fetch_template('ow_header') . '"');


J'obtiens une page correcte, mais comme je veux quand meme changer le header,
Lorsque je laisse cette ligne j'obtiens:

Parse error: parse error in C:\Program Files\tools\wamp\www\wii\forum\f.php(49) : eval()'d code on line 19


Avec un paquet de caracteres illisibles.

Quelqu'un a une idée ?