Gros Problèmes install java.comm API !?!

Affb1 Messages postés 1 Date d'inscription lundi 15 avril 2002 Statut Membre Dernière intervention 15 avril 2002 - 15 avril 2002 à 13:37
al_b07 Messages postés 24 Date d'inscription lundi 27 septembre 2004 Statut Membre Dernière intervention 4 octobre 2004 - 27 sept. 2004 à 10:41
*** Javaïste convaincu ! ***

QUI A DEJA INSTALLE L'API JAVA.COMM 2.0 ?

Pour ma part, j'éprouve de grosses difficultés à faire tourner cette API (sous Windows).
Je souhaite réaliser une appli. de communication entre 2 machines sur le port série, et je ne parviens même pas à exécuter les exemples fournis avec l'API !?!
J'ai configuré l'API comme indiqué dans la Doc. :
comm.jar et javax.comm.properties dans <jdk>\lib
win32***.dll dans <jdk>\bin,
et <jdk>\lib\comm.jar dans le classpath

J'ai essayé d'exécuter l'exemple BlackBox, mais sans résultat ! (en ayant préalablement placé le blackbox.jar dans le classpath of course)
J'ai droit à un magnifique : NO SERIAL PORTS FOUND

Si quelqu'un a essayé cette API avec succès, pliz aidez-moi.

Merci d'avance

Affb1

2 réponses

cs_spong Messages postés 5 Date d'inscription lundi 19 mai 2003 Statut Membre Dernière intervention 25 août 2004
20 mai 2003 à 21:21
Moi je n'arrive pas a faire tourner mon programme.
Sous quelle windows es-tu?

J'arrive a compiler mon prog mais pas a le faire tourner.

Pourrais tu me donner tes CLASSPATH et PATH.

Merci
0
al_b07 Messages postés 24 Date d'inscription lundi 27 septembre 2004 Statut Membre Dernière intervention 4 octobre 2004
27 sept. 2004 à 10:41
place the win32com.dll in <jdk>\jre\bin directory.

Place the comm.jar in <jdk>\jre\lib\ext.

Place the javax.comm.properties in <jdk>\jre\lib .

et là tout de suite ça marche mieux, parce que j'ai déjà eu le problème. Quand on le met directement dans <jdk>\bin, etc, ça chie.

Et n'oublie pas le java ça déchire sa race...et vive l'api
0