JSP/SERVLET

Résolu
cs_limalima Messages postés 124 Date d'inscription dimanche 31 août 2008 Statut Membre Dernière intervention 16 décembre 2010 - 2 sept. 2009 à 01:09
cs_limalima Messages postés 124 Date d'inscription dimanche 31 août 2008 Statut Membre Dernière intervention 16 décembre 2010 - 2 sept. 2009 à 22:28
Bonjour,
j'ai un programme qui permet de modifier une tables(insert into ...), quant je l'execute la methode d'insertion fonctionne, mais quand je fais ça via une servlet(en instatnciant un objet de ma classe et en appelant la methode dessus, alorrs la ça ne marche plus!!!

voici l'erreur:
-------------------------------------

java.sql.SQLException: No suitable driver found for jdbc:mysql://localhost/planning
at java.sql.DriverManager.getConnection(DriverManager.java:602)
at java.sql.DriverManager.getConnection(DriverManager.java:185)
at AccesBase.(AccesBase.java:21)
at ServletControl.doGet(ServletControl.java:66)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
at java.lang.Thread.run(Thread.java:619)
merci de m'aider

1 réponse

cs_limalima Messages postés 124 Date d'inscription dimanche 31 août 2008 Statut Membre Dernière intervention 16 décembre 2010
2 sept. 2009 à 22:28
bonjour,
la solution etait :
je suis allé dans buildPath et ensuite librairie et j enlevé(remove) mon driver et je l'ai remet après(avec add externalJars) et ça marche!!
3