Problème avec RECHERCHEV() [Résolu]

Signaler
Messages postés
1207
Date d'inscription
dimanche 20 avril 2003
Statut
Membre
Dernière intervention
4 juin 2016
-
Messages postés
1207
Date d'inscription
dimanche 20 avril 2003
Statut
Membre
Dernière intervention
4 juin 2016
-
Bonjour à Tous,

J'ai un problème avec la fonction RECHERCHEV d'Excel.
Je vais essayer d'être clair.

Dans le 1er onglet d'une feuille Excel, j'ai un tableau dont la 1ère colonne contient des numéros de produits. Les colonnes suivantes vont contenir des données situées sur un 2ème onglet. J'ai donc utilisé la fonction Recherchev() comme suit: RECHERCHEV($A:$A;Access!$A$3:$E$26;3;FAUX) où Access est le nom du 2ème onglet. Jusque là tout marche bien.

Le problème étant que les données (qui proviennent de requêtes Access) du 2ème onglet changeant régulièrement j'ai automatisé un peu le système en faisant un copier-coller avec liaison et là le résultat du Recherchev me renvoie "N/A", j'imagine parce que la cellule résultante contient une formule et non une valeur.

Quelqu'un aurait-il une solution à ce désagrément avant de revoir toute la conception de mon tableau.

Merci d'avance

Calade
A voir également:

2 réponses

Messages postés
672
Date d'inscription
mercredi 22 janvier 2003
Statut
Membre
Dernière intervention
2 juin 2016
1
bonjour
Plusieurs erreurs possibles

1- le premier param $A$A ->A1 puis A2 glisser une formule
2- Recherchev s'utile aussi avec ESTERREUR pour controler N/A
3- La requete access rend t'elle des valeur triéés sur la colonne A , regarder si l'influence d'un tri Excel (Données/trier) change le résultat dans l'onglet Access
4- et donc peut être faut t'il forcer le format de la colonne A
Messages postés
1207
Date d'inscription
dimanche 20 avril 2003
Statut
Membre
Dernière intervention
4 juin 2016
9
Bonjour,

Bingo, c'est ta solution 4 qui m'y a fait penser. Dans la 1ère mouture du tableau la colonne A (celle source) était numérique et le tableau collé normalement était aussi numérique, donc pas de problèmes.

Dans la 2ème mouture qui posait problème le copier-coller avait transformé la colonne A (celle cible cette-fois) en Texte (le champ correspondant sous Access l'est aussi donc c'est normal, mais je n'avais pas vu le petit triangle vert en haut à droite de la cellule trop obsédé par le reste.

Petite question subsidiaire, y a t'il un moyen de passer d'un coup toutes les cellules de la colonne A qui m'intéressent au format texte plutôt que d'insérer une quote avant chaque valeur ce qui peut vite devenir fastidieux.

En tout cas merci de ton aide.

Calade